1writer - hashtag linking

Hi,

Hashtag linking not working in 1writer.
They’re acting as H1 markdown title.
Can anyone point me to my mistake, and how should I correct it so that hashtags work as links to all .md files containing a #tag?

Just to confirm, you aren’t adding a space between # and the tag?

#hashtag
# Header

No, I’m not.

Title - # Title
Hashtag - #hashtag

They’re only active links in preview mode. If you’re in edit mode, they don’t work.

1 Like

Exactly.

When I go to preview mode, #hashtag displays as # title.

There’s some setting that is precluding it to work. I tried disabling and enabling the Hashtag switch, with no results.

These are my other settings:

With those settings:

Text mode …

Preview mode …

Exactly!

The issue is #hashtag1 and #hashtag2, both without the space, do not display, in Preview mode, as hashtags, but as title H1.

That is the issue I cannot solve.

That’s weird, with the same settings it works as intended for me:

Works fine for me too.
@vgrovpro can you share a document (or a test document) that you see this behavior in, so we can try it on our computers?

@JohnAtl, hi.

Just ran an experiment.

  1. Created a file, exactly like yours above, under 1writer default directory

    Hashtags work (!).

  2. Move the very same file to an iCloud directory.

    Hashtags turn into H1 titles (???).

  3. Moved the very same file back to the 1writer default directory.

    Hashtags work again (!!!).
    

Something is odd. Bug?

For me it works in both places… (on version 3.0.3 btw)

stupid question: did you try to delete and reinstall the app? :eyes:

I do know that folders outside of 1writer’s default iCloud location are treated slightly different. But all the dev mentioned was that 1writer can’t do full text search on “external locations.”

I did, to no avail,
Thanks.

Hi!

Thanks for jumping in.

If I may ask - which iCloud directory is the default 1writer directory?

I cannot see it …

In iCloud Drive it’s the 1writer folder. Inside the app it’s just called “iCloud”.

In my case, the 1writer Folder is an iPhone Local folder.

(1) Deleted 1writer
(2) Reinstalled
(3) Selected a different folder as the default folder

Did not work.
The default folder is an iPhone local folder (!).

(4) Moved the files where #hashes were working as H1 headers to the local iPhone folder.

#hashes work, provided they do not include “-“ characters (…).

:confused:

Soo, apparently:

Scenario 1

I may be setting the app incorrectly.

Scenario 2

(1) The app does force its folder to be an iPhone local folder AND

(1.1) when the file is in the 1writer folder, #hashes work

(1.2) when the file is NOT in the 1writer folder, #hashes DO NOT work.

Let’s hope it is scenario 1.

This morning I was toying with the app, and noticed that hashtags work in the local folder and in the default iCloud folder (the one that the app creates for itself: /1Writer) but doesn’t in another external locations such as a folder manually created in iCloud Drive (something like /personal/notes).

I’m afraid it’s an app behavior, not user error.

Edit: I contacted the support, let’s see if something comes from them.

Hi @memex,

Thanks for that.

Odd thing -

In my case 1writer did not create its folder in icloud driver, neither on the iPhone, nor on the iPad.

(The other apps did - Pixelmator, Geniuscan, Drafts, etc.)

Solved the puzzle.

  1. When you set the app, it asks where you want to file your notes.
  2. Point to iCloud
  3. 1writer creates the 1writer directory in iCloud.
  4. Move files I want 1writer to “index” tags, and note-link (“wikilinks”) to iCloud 1writer directory.
  5. Tags are working.
  6. Note-linking is working.

@KevinR, @quorm, @memex, @JohnAtl - thank you for your help!

1 Like

FYI this is the developer’s response:

Hi Emanuele,

This morning I was toying with the app, and noticed that hashtags work in the local folder and in the default iCloud folder (the one that the app creates for itself: /1Writer) but doesn’t in another external locations such as a folder manually created in iCloud Drive (something like /personal/notes).

I’m afraid it’s an app behavior, not user error.

You are right. Hashtags are not supported in external folders. That’s why they are rendered as titles in preview mode.

Hashtags in external folders will be supported in a future update, along with full-text search.