AirPods Automatic Device Switching in iOS 14 is Here!

My Airpods picked up the latest firmware update last night and let me tell you it is real. I went straight from listening to overcast on my phone to opening a video on iPad - as soon as I hit play it instantly switched over. Hit play again on your phone and you’re back to the podcast. This was always the dream for me when Apple first pitched AirPods. I might not need two sets of Airpods anymore. I kept my old version 2 set because connecting to the Mac was such a hassle. :slightly_smiling_face:

Side note - in the latest developer beta of Big Sur I can’t get any AirPods devices to connect - so I haven’t been able to test the seamless switching between all 3

3 Likes

Did this come out for Beats too, or is it just an AirPods update?

Is this only for the new(er) generation AirPod?

Or also for the very first ones?

According to this MacRumors article:

Automatic switching works with the ‌AirPods Pro‌ and the second-generation ‌AirPods‌, and it is not compatible with the original ‌AirPods‌. It also works with Powerbeats, Powerbeats Pro, and Beats Solo Pro.

So Beats, yes. Original AirPods, no.

2 Likes

I’m looking forward to getting this. I switch once or twice a day; it’s inconvenient.

1 Like

Yes! This is great!

I tried it on Big Sur beta, and it doesn’t seem to work. But once I connected my Air Pods to both my iPad and iPhone, I see the switch whenever I move from one device to the other. It’s fantastic.

1 Like

this solves my “no overcast on mac” problem… for now :slight_smile:

1 Like

Loving the feature!!!
When AirPods came out I was under the impression that the way they work now was how they would work all along. Remember how frustrated I was when they did not switch automatically.

1 Like

Completely agree - I was in the confused camp too. I think some of it was because calls did route no matter which device you were on.

For awhile I wanted a little button on the charging indicator that popped up when you opened the AirPods lid to have a “tap to connect” button, but this is a million times better.

So far this isn’t really working for me. I have been on the beta cycle all the way through and even with the GM yesterday, it will still not automatically switch.

Check your firmware version in your phone settings->general->about while your AirPods are connected. After I read the news, I charged my phone and AirPods overnight and it was there when I woke up. My firmware version on AirPods Pro is 3A283.

Do your AirPods Pro already have the latest firmware (3A283) installed?

It did not work for me yesterday, I did not have the time to explore the issue then. Today, it works like a charm and my AirPods Pro are on version 3A283. And I have not even installed the latest iOS 14 version (I deleted the beta profile during yesterday’s keynote in order to make sure to switch to the iOS release version).

If your AirPods Pro are not running the latest firmware, you can try to enforce the update:

The iMore article is a little a old and it refers to an older firmware version, but the tips regarding forced updates are still helpful.

I am current on the latest firmware. I am enjoying the spacial audio, but no device switching yet unless I am expecting the wrong thing. I was expecting that if I am watching a movie on my iPad and then pickup my iPhone and start playing a song on it that the AirPods will jump over to the iPhone and play without me going into bluetooth settings and hitting connect. As of right now, I still have to do that, and that is in both directions.

Hmm - definitely something is wrong. Your expectations are correct and working for me. One giveaway is whenever I reach the lock screen for my iPad or iPhone the graphic “AirPods Connected” will pop in from the top.

1 Like

I have rebooted every device, and still not working. I am sure it will start eventually

It’s just… wow! Hope it doesn’t take too long to make its way to the macOS

1 Like

How does one turn this feature off? With the number of devices in my house, it’s more inconvenient than convenient.