Alfred 4 no longer includes Dropbox files or folders in its search

After I got the Dropbox update and moved the Dropbox folder to its new location, Alfred is no longer returning any results from Dropbox.

I’ve re-indexed Spotlight, and can confirm that Spotlight has no problem finding the Dropbox files.

As you can see in this screenshot, ~Library/CloudStorage is included in my sarch scope results. I get results back from iCloud without an issue.

Is there something I’m missing here? Does this work for Alfred 5 users? I haven’t updated yet because of a couple of my critical workflows aren’t available in v5.

1 Like

It doesn’t work in Alfred 5, either. Luckily, I don’t need to search DropBox as I only use it for shared files (which I keep originals for elsewhere), but I would still like a solution if there is one out there! I’ve also added CloudStorage and have had no luck.

This would kill my main workflow. All my work files are in Dropbox, and I access many of them through Alfred 5 throughout the day.

How long can I avoid the conversion to the new Dropbox file storage locations? Will it be possible for the Alfred devs to issue a fix?

I’m in a bit of a panic because not only will it slow me down, I rely on Alfred to know that an important file might even exist.

Vero is claiming you need to rebuild the local index so macOS resumes providing metadata about the Dropbox files. She had a couple other potential troubleshooting steps.

Assuming it works, it’s still not good if a lot of users have to do this after Dropbox updates, and macOS doesn’t give Alfred the info to detect and trigger it.

1 Like

I added my onedrive folder location in Alfred search and it works fine.

1 Like

Using Alfred 5, I had the same search problem with the Dropbox update and move to ~Library/CloudStorage. No Dropbox files showed up in search, despite having ~Library/CloudStorage in my search scope. OneDrive files, also in the new CloudStorage location were reported by search. I tried other troubleshooting suggestions, but what fixed it for me (and I’m not sure why) was adding my home directory to the search scope as was suggested in an Alfred forum post. In other words, a simple naked ~ in the search scope.


Indeed, this has been brutal for me. Didn’t realize how often I just hit Command Space and wrote find filename to get it in Finder quick.

I tried this, and it didn’t do the trick. But it was my first thought, so great minds think alike.

Magic! This is the solution. I’m a little worried that adding the entire home directory is a bit of a crazy hack and a mess, but I’ll take it if it means I can use my computer the way I want to.

I wonder if it’s because Dropbox left a symlink in the home directory that points to its new folder? Odd that this works, but OK. Thanks so much for your help! I hereby bless you with all the edible internet cookies.

1 Like

Maybe “~Library/CloudStorage” wasn’t enough but “~” (your entire home directory) did include what was needed? That suggests if someone can pin down exactly what is needed, you won’t have to put your entire home directory on this search path.

1 Like

According to Alfred, it should be enough to have ~Library/CloudStorage. I also tried a variant with ~Library/CloudStorage/Dropbox and that didn’t work either.

The other thing that’s interesting, if anybody is interested in tracking this down, is that everything in Dropbox is prepended with a cloud in the file path (see the image below). That’s not true of the files located in iCloud Drive.

The only explanation I can come up with is that I have “Folders in Home (excluding ~Library)” checked off in the search scope in Alfred. I’ve manually added in the Library path I want below (as you could see in my previous screenshot), but I wonder if Alfred is tripping over itself here.

I don’t think it is just related to Alfred. Since this upgrade, Hazel can no longer see the content of files in my Dropbox folders either.

I’d love it if someone found a solution.

So far, this is the only conclusive way I have seen to resolve this problem: Solved: Re: Spotlight Search Doesn't Link to Files in Drop... - Page 29 - Dropbox Community

Now use Maestral to manage Dropbox, which allows you to keep your DB folder wherever you like. I simply set up Maestral, deleted the DB folder then renamed the new Maestral folder to “Dropbox” all my links and automations still work as expected and DB syncs fine without the constant massive memory hit.

This would be a great solution if I didn’t extensively use Dropbox’s sharing features, but that’s (unfortunately) a huge reason why I use Dropbox over other solutions. IIRC, Maestral doesn’t support those features.

1 Like

Yep I can see the issue there. Could you use a single site browser logged into DB on the web to handle sharing maybe?

I can totally see why that would work for some, but for me I am not worried about the CPU usage or the RAM usage (have plenty to spare), and I prefer the convenience of the built-in Finder tools. They totally work fine.

I’d also imagine the app consumes less resources now that it’s been updated to the latest guidelines and rules.

The recommendations in this post fixed the problem for me: Searching Dropbox files not working - Discussion & Help - Alfred App Community Forum

1 Like

The Ventura 13.3.1 update appears to have resolve this for me.

I didn’t do anything other then the MacOS update, but I can now search Dropbox files in Alfred again.