Anyone else hacked off with the new text selection system?

I’m super frustrated at trying to select text on my mobile device.

It just feels bonkers trying to select a word and finding it select the paragraph, or worse trying to edit a word and that madness

:rage:

2 Likes

It’s not great. A particular problem is editing a URL in safari. When you tap on the address bar is auto-highlights the whole URL. You can no longer double tap to select one component of the URL without deselecting the URL. Deselecting is not easy.

Whole thing is pretty frustrating, and a massive regression in functionality.

6 Likes

Strange, I have no problem selecting a part of an URL. When I double tap, it selects one „word“, e. g. „facebook“, then I can adjust with the handle what I need.
I hated the old text selection system so much, it never worked, you didn’t get the pop up when you needed it, so I really looked forward for an update. So far, it seems to work better for me.

Also, I really like the swipe keyboard, works much better than third party solutions I tried before. There are only two things that bother me:

  • sometimes it puts two words together, which makes sense from time to time. But in other cases, I want to delete only the second of those two words and it will automatically delete both, even though the first of the couple was correct.
  • It always adds a space before the next word or type. When I write a quotation mark I need to delete that space, but if the word has been „swiped“ pressing backspace deletes the whole word, which is fine in all other cases but annoying in this one. Probably just have to get used to typing out a word when it’s followed by a quotation mark.
3 Likes

When I swipe and add “quotation marks”, the keyboard automatically deletes the unwanted space. Like it does for a full stop.

Or should that have been “quotation marks,” with a comma there?

There’s actually no one single definitive rule for the use of quotation or speech marks in English.

Though teachers often tell you differently.

That’s strange, I just tried again and it happened as you say. But I definitely also have the other experience from time to time.

Playing with this a bit, it seems like when using the swipe keyboard won’t put a space between the word and a following quotation mark if there’s an earlier quotation mark that its paired with. If there’s no earlier quotation mark, it leaves the space. The system is probably trying to figure out whether you’re typing a closing quotation mark or an opening quotation mark and leaving/not leaving the space based on what it thinks you’re doing.

1 Like

Maybe I was deciding to put the quotation marks there afterwards then, in those cases where it happened, starting with the closing mark. I don’t remember, but that might be the case. It would actually be a pretty clever solution if it works like that.

Sounds like you are having better luck than me on the word selection front. I am still VERY frustrated still not even being able to select and correct words that come up in red underline.

On the Swipe functionality I only partly agree. Yes it’s great that they now have something and I totally agree with the annoying deletion business… However, I personally prefer Swiftkey for a number of reasons compared to Apples Swipe functionality. If Apple took a leaf from that book I’d be very very happy not to have to make that extra keyboard selection

3 Likes

This

I really like the swipe keyboard. Placement is sometimes wonky. I pretty much always want it by my right thumb, not up by the search bar.
When it appears by the search bar, it’s a zero-thumb game. :upside_down_face:

I just tried the URL selection thing and found that by double tapping an element of a selected URL the selection changes to just that element.

I want to like the swipe input more but it’s a real fight against my muscle memory. I also wish it would just put in a space when I lift my thumb.

Agree @Marcus it is a step backwards in ease of use. Very frustrating at times.

2 Likes

But you can move it to wherever you want, in case you didn’t know yet.

1 Like

Yep. Every time it appears in the wrong place, I move it back where I want it :slightly_smiling_face:

On my iPad it’s started playing a game where I move it under my left thumb, then when I start typing it jumps to the right and won’t move.

1 Like

I like the new text selection a lot, overall. Selecting one slug in a URL in Safari is taking some getting used to as the tap target seems to be 1-2mm higher than where my thumb naturally hits. I would also like to see triple tap select an entire line. Dragging the cursor is a massive improvement, obviously.

1 Like

To put an insertion point in a URL requires tap, double-tap, tap. Not a fan…

1 Like

Yes. I feel this way too. There are a few selection improvements, but I find it very difficult to place the cursor where I want it to go.