APFS Time Machine Drive Locked to Read Only

Two days ago time machine stopped doing backups. I have had this sort of thing pop up from time-to-time in the past and simply reformatted the drive and started over. This time, however, the culprit appears to be that somehow the drive magically became read only with no option for me to reset permissions. No lock to click to enter my admin password, just lists the drive as being read only. What this means is that I can do nothing, including reformat the drive. Anyone else ever encounter this? I have tried erasing the drive in terminal but get no further there. Any thoughts or help would be appreciated.

image

Are you comfortable with using Terminal?

Yep, have tried erasiing the disk in terminal with no luck. That’s actually what alerted me to the permissions issue. Starting to think the problem might be with the disk itself. Even though finder and DU can see the disk other apps can’t.

The first thing to do would be to find the disc in the filesystem. That would be in /System/Volumes I believe. If it’s there look at its permissions using

sudo ls -@ld /System/Volumes/<disc name>

Post the results.

First, I listed all my volumes using “diskutil list” and here is the info for the disk in question:

When I issue the terminal command you suggested:

Probably needs quotes around the pathname of the the drive because of embedded spaces in its name. Unix is not as forgiving as MacOS in that regard.

I did try putting quotes around it but it comes back that the volume does not exist.

But wait a minute, you’re using the command-line version of the diskutil command? What about the interactive (GUI) version of the Disk Utility app? Have you tried doing a clean shutdown and restart of your Mac followed by trying to run First Aid via the Disk Utility app on the read-only drive?

Try this in the terminal. Will just give a list of drives but shows additional info.

diskutil apfs list

Edited: In looking more carefully @karlnyhus post above, I would try as he suggests. If the Disk Utility app doesn’t find the drive then the terminal l command that I suggested won’t either.

1 Like

Believe me, I have tried to get DU to work more times than I can count. Read a number of things that suggested working in terminal might get results.

That information was not in your OP. :slightly_smiling_face:

DU absolutely sees the drive. I can post a photo later after work.

I have not personally experienced this problem but I get lots of hits in Google for it, so something is going on and you are not alone.

Yeah, me and Google were good friends for much of yesterday. What I am experiencing is exactly what happens if drives are NTFS formatted (my drive is APFS formatted). Interestingly I have Paragon’s NTFS for Mac installed and it does not see my drive (sees the other externals I have connected).

1 Like