Can make but not receive calls on my M1 MBA

Set up everything for calls on my Mac, via my iPhone. It was working. Both incoming and outgoing. But somehow now incoming calls no longer “ring” on my Mac. No notifications, no badges, no nothing.

I can still make outgoing calls with the Mac just fine using Facetime.

Both devices are on the same wi-fi network, and I’m not seeing anything obvious that’s wrong. I’ve tried turning Facetime off and then back on. Facetime’s notifications are enabled.

It seems much of the online help I’m seeing assumes that incoming / outgoing are a package deal, and either they’ll both work or not.

But this is just the incoming that’s an issue.

Any thoughts?

ETA: Turned it on for my iPad, and it works there too. The Mac is the only device that seems to have the issue.

ETA: It worked for a day. Then troubleshooting something else required me to sign out and back in on iCloud on the phone, and now it doesn’t work again.

I’d be happy to “jiggle the handle” in some way if it would get it working, but I’m kind of stuck on what to try.

I am having a similar issue with Messages not working with my M1 MBP. It did work, then it stopped. Everything is set up correctly as far as I can see. I confirmed on my iPhone, but my MBP just won’t do Messages now, even though it works everywhere else, including my Intel iMac. I have given up and been waiting on a Monterey patch.

Spent a long time on the phone with Apple Support. After a long time on the phone, signing out and signing in on iCloud on all my devices, and them (no joke) wanting me to completely reinstall macOS on my Mac, a reset of my mesh network solved the problem. The reinstall part of the conversation was something along the lines of:

Me: No, I’m not going to set up my whole Mac again as a troubleshooting step. This computer is almost brand new.
Rep: No, you won’t have to set up your computer again. It doesn’t delete any data. But be advised there is a risk you may lose data.
Me: Wait…WHAT?

I’m still trying to figure out how the process wouldn’t delete any of my data, but I could still lose my data.

Anyway, I’m hesitant to credit “reboot the mesh” as the solution, because it’s a solution I’d already tried that didn’t work previously. And it wouldn’t explain why my Mac Mini on Catalina and my iPad didn’t have any issues, but the Mini on Big Sur and the MBA on Monterey did.

That said, my issue did match an issue that apparently they have senior tech people trying to figure out. So maybe there’s hope for a fix in a point release…?

It sounds like they were just going through their basic troubleshooting steps. Apple support always want to go with the reinstall route (and I don’t know how you would not lose data either). This is an annoying problem, but it’s not worth doing that. My problem is definitely not the router, since I rebooted it a few times the other day when I got a new modem.

Glad they got it fixed for you! Hopefully, mine will just fix itself at some point. I have a feeling it’s iCloud related.