Cannot access email in apps but can in browser

Hi everyone,

I am experiencing an issue with my email that has been quite frustrating. I typically use the Spark app on my Macbook to manage my email, but I have also tried using other apps such as Airmail, Mimestream, and MailMate. However, all of these apps have suddenly started having issues sending and receiving my emails. The problem is intermittent, some days the apps work fine, while other days like today, I can’t do anything with them.

I have multiple email accounts, some are Gmail accounts, and some are GSuite accounts. Strangely, I am able to access all my emails without any issues through my web browser and on my iPhone app using Spark or Airmail on the same ISP as my laptop. This leads me to believe that the problem is not with my email accounts, but something specific to my MacBook settings.

Although I initially thought that the issue could be with Google, it’s unlikely since my partner also has an email with GSuite, and she is not experiencing any issues with the Spark app. I also use Starlink, but I don’t think that has any bearing on the current issue.

Do you have any ideas or suggestions on how to resolve this issue? Thanks in advance!

Have you tried using the native Apple Mail App?

I will try it when the other apps stop working again, because now everything is working again. It’s very random, but seems to happen mid-morning almost every day.

I can’t bear to use apple mail without my gmail shortcuts, but I’ll test it out for a data point.

A little update, the apps stopped working today as expected. I tried Apple Mail and it does not work either. Any other ideas? This seems to always happen mid-day strangely enough.

Is ist always around the same time?
Maybe your ISP is reconnecting after 24hours?

I would also suspect ISP issues. When this occurs, open terminal and do a traceroute for the imap server, i.e. traceroute

It seems to be, but I haven’t kept accurate notes of the time. I can still access the internet otherwise when this is happening.

I’ll give it a try next time it happens, thanks!

I’m currently traveling, but when I get home I’ll try bypassing the Starlink router and using my own, so I can change the DNS, Starlink uses, which is provided by Google so I don’t think that’s the issue, but it’s a worth a try.