Cannot install Mojave


there is a major problem with a Mojave installation on my side :frowning:

I am quite an old iMAC late 2013 a 3TB Fusion Drive. I had installed on that disk the latest High Sierra Version and as it was qualified as compatible I decided to update the system to Mojave - about ten hours ago …
The update procedure works fine at the beginning - slow but OK. It downloads the image, starts the setup, asks for the disk, and kicks off the implementation. At about 75% of the installation the update procedures stops and does not continue.
Twice done, I have called Apple Support, who guided me through the steps to do an “First Aid” on the disk with the Disk Utilities in the recovery system. There the system now stalls - it is checking the catalogue file system for the last two hours or so. I guess the system has some problems with file access rights, as the catalogue check takes so long. Which makes me also think that it is not likely to have a HW issue, as Mojave installed up to 75% …

Did anybody else have issue with the Mojave installation ?

Thanks for some thoughts!

Sounds like the exact same issue I’m having. You’re not alone.

1 Like

Somehow that makes me feel social :wink:
I ran 3 DiskChecks via First Aid … and it made very slow progress … buuuut the 3rd worked successfully.
Now I am currently trying to install Mojave again - if that works I will do another complete backup, repartition, format and reinstall … and then I should be fine from doing any update on this system again, a new one is already planned :wink:

I am on attempt #4. I reluctantly called the only “Mac Friendly” IT guy I have here at work and told him what I’ve done. Of course i have my backup, but I’ve lost a full day of work now. Waiting another 45 minutes before restoring from backup (again) and waiting for the “point 1 update”.

1 Like

My system shows now 2,5h installation time … not the best update experience …
do you know if I can restore from a time machine backup total folders or only individual backups?

I had a similar experience when going to High Sierra, really sorry to hear about your troubles. I was ready to jump to Mojave, but will be holding off a little longer. Thanks for the report, and hope you all get back up and running soon.

1 Like

I have heard about this issue on Twitter, seems to be only affecting those older iMacs with the fusion drives only, no issues on the traditional hard drive or the solid state drives. This is another reason for me to just go completely SSD on any future purchase.

Related to the APFS conversion perhaps?

I did my late 2013 iMac last night, with a 3 TB Fusion drive. It installed without a hitch from High Sierra. I checked and the drive is now APFS

I think this is APFS related issue.

I restored back to High Sierra 10.13.6 on my Mid 2014 MBP (2.8GHz i7 16GB DDR3). I did notice that I am frighteningly low on storage space (only 30GB left out of the 500 I have). I suspect that may have been part of my issue. I have cleaned out some of the cruft and may try again over the weekend with almost 70 GB of space.

I’m feeling smug for waiting for 10.14.1 to upgrade my Fusion drive iMac. Seems like APFS is a “bag of hurt” unless you have an SSD.

An update to the status for those who are interested:

  • The update did not work without erasing the desk, so I had to erase the disc via disk utilities and then updated the system to Mojave.

  • part of the update process was my intention to migrate my old data from an existing time machine back up.

  • during that migration process the system halted for more than four hours. Apple support asked me to stop the process which caused the whole update process not to be completed and so I had to erase the disk again and reinstall the operating system (3rd time).

  • so I reinstalled the operating system and started the migration process of my existing data via the migration assistant in a complete installed Mojave.

  • this is running right now for the last three hours and making only slow progress.

The Apple Hotline in this whole issue (I have spent like four hours with them on the phone) was of minimal to no value to my problem, their technical expertise is neglectable and probably based on a two day training or so.

I will keep you posted on the outcome :wink:

Yes, I believe that was what they pointed out.

1 Like

Cleared the hard drive and tried again. No issues this time!

After trying out Mojave on my iMac since Monday, I took the plunge and upgraded my 2016 MacBook. All went smoothly, although I was a touch uneasy after reading of people having issues with the Mojave installs on MacBooks. I did have a current TM and CCC backup as fallback.

Seems reasonably solid so far!

After careful consideration, I decided to go for Mojave on my 2017 iMac. I am happy to report that there were no issues. Glad to be off High Sierra :grin:

Sorry, I have not keep you update on the end of the story yet - been traveling quite a bit :wink:

Just to let you know how it ended up:

picking up from my last update - installing Mojave and trying to migrate my old data, which took more than 30 hours and even though I did not opt in for installing the Apps (I am not a big believer in migrating the apps from an old system), the migration process ignored my choice and migrated also the Apps … don’t now why.

That led to the fact that some of the migrated Apps did not really work well afterwards specifically Office 365 (which I have to use due to company constraints) but also SW like Final Cut Pro, the Adobe Suite and some other stuff and so I spend another day or so deleting those installed Apps and re-install them.

After all, it was a very cumbersome process this time - the worst so far I have experienced in 15 years of Apple products. Terrible was the Apple Phone Support, who basically did not provide any help whatsoever just consumed my time and told me things I already knew - I do not know about the US but the quality of the phone support here in Europe is below my expectations by far.
The best situation I had with the phone support during this process was a second line support “expert” with whom I have spent just about 30 minutes to explain the issue and all steps I have taken so far - all over sudden he asked to be patient for some minutes and after three, four minutes or so, he came back telling me that they have an urgency in the office and he will send me a link how to migrate existing data. He did not offer to call back or anything just hung up the phone and was gone - I received an email with a standard migration description and that was it … well, I understand any urgency issue but then I expect somebody to contact me after the urgency is over. For me it sounded more like a made up story to get rid of me.

Anyhow, the system works now without any problems, performance is good for the old system and it is stable … after all :wink: