Can't access ad publisher dashboard from Mac only-- for about a week

As a side hustle, I run a website which generates ad income. Recently, I stopped being able to access the publisher dashboard on my Mac. (A 2017 iMac running Big Sur 11.6). It just times out when I try to access any of Adthrive’s web properties. This has been an issue for about a week.

Note that it never worked on Safari on the Mac.

Note that “” is whitelisted on my router and it works on my other devices just fine.

I have tried

  1. Four difference browsers (Safari, Brave, Chrome, even Opera) with all adblocking functionality turned off
  2. Incognito mode or equivalent (the suggestion of Adthrive’s help desk)
  3. Changing DNS (was using back to the ISP default both on the computer and the router)

I have not tried a different wifi network because, well, it’s a desktop.
I feel like there is some sort of hidden system setting that is causing this.

The photo is from Opera when it tries to load the site-- which seemed to be the most informative. The others seemed to never respond.

Any help or suggestions would be appreciated

Have you installed any ad or cookie blockers recently?

No definitely not. Seems to be specific to my computer as I used my son’s log in on my computer and had the same issue. Really weird.

what happens if you setup a new user on your Mac and try from that?