Can't delete watch complications after latest update

I finally got around to updating my phone (13.1.3) and my watch (6.0.1), and find all my complications returned to the watch (where I can’t delete ones I don’t want) even though according to the watch app on my phone they shouldn’t be there. Any advice? Some of them are native apps, but some are 3rd party ones that have watch complications that I don’t want to use on the watch. I looked into the reset home screen layout, but even though I ok’d the warning message, nothing happened. Needless to say, I turned everything on and off again but without success. I suppose the next step is re-pairing from scratch, but thought I’d seek wisdom first.

I have not had this problem with 13 & 6, so maybe if others report no issues then a reset is in order?


1 Like

Have you tried a hard rest on both the iPhone and watch? I have found a hard reset after major software updates tend to put everything back in order.

Sounds like a possibility, but I’m not sure what a “hard” reset is compared with a re-pairing - if it’s “erase apple watch content and settings,” I will try that for sure. :slight_smile:

A hard reset on the watch is holding down both the crown and side button together until the Apple Logo appears and then letting the buttons go while it resets. Depending on which iPhone you have the hard reset will be done using a combination of the sleep button and home button (if you have one) or the volume buttons, you will have to look it up.

Yes, I tried that. Looks like a re-pair is in my future! Thanks though.