Can't load DaringFireball on my home network

So I can’t load DaringFireball in Safari or Chrome on my Mac or load the RSS feed on Reeder. I can’t load it on my phone (when connected to Wifi) in a browser or Reeder either. But I can connect to it on cellular and other networks just fine.

What settings am I looking for? I can’t imagine this is a port issue, otherwise I’d be having trouble with other websites, and DaringFireball is the only one.

Is it my DNS? My mediocre ISP (Mediacom)?

It’s always a Timeout Error for what it’s worth

It may indeed be a DNS problem. Have you tried temporarily switching to another DNS server in the network settings, e.g. Google’s DNS server or OpenDNS ?

I haven’t yet. Wanted to consult a forum like this one first.

Fully agree here. Sounds 100% like a DNS issue.

Thanks kindly. I’ll try switching my DNS tomorrow. Might be worth calling my ISP though to get them to try and fix their own DNS.

Mate of mine stuck with the same ISP (and thus using the same DNS) is not having a problem connecting.

A diagnostic you can try is running a trace route (tracert) to the domain from your iOS device using an app like iNetTools (free app … with some basic ads as you’ll see below). When you run the trace it will tell you where it is trying to get to and you can follow it on each hop to the next router and get an idea of either where it is timing out or if it is just a failure to find the DNS record.

Here’s how it looks for me.

I can see it go from my home network out to Plus Net (my ISP), then on to the BT infrastructure and so on. I don’t know the exact details of locations of routers, but I can get the gist of where the packets are travelling from and to.

Hope that helps.

Here’s what’s showing up for me (ran it in Terminal)


“mchsi” is my ISP.

OK so your DNS is returning the IP address so it can’t be that unless you had an intermittent issue. Also it does seem to get there though hops 9 onwards are much slower for response than the previous ones.

Q1) How long has this been an issue?
Q2) Have you tried rebooting your router to resolve this?
Q3) Is there anything on your network that you go through that could cache queries? Caches can corrupt and cause all manner of seemingly bizarre issues.
Q4) Do you see any difference between being wired into your network vs. WiFi?

(Also, apologies, I missed on first read the bit where you included Mac otherwise terminal would have been my first suggestion).

This has been an issue since March or so. I’ll try and look into a way to wipe my cache, but I haven’t tried wiring into my network in years. I don’t have an ethernet adapter for my current MBP, but I might try it with my terrible PC if I can’t fix it through a cache wipe. Much appreciated.

I thought I tried it on my PC, but I must’ve been mistaken. So it’s not working on any of my Apple devices – does the hosts file sync over iCloud somehow? Is there another preference that can account for this?

If that were the case it would presumably not work on cellular either and the trace route from the Mac would have failed to get to the domain.

Your constant for your Apple device issue, as I understand it at the moment, is your wifi network. But you haven’t said yet if you rebooted the router and is your PC connecting via wifi (to the same access point) or ethernet?

If you don’t have something explicitly caching locally for your network gateway (which is typical for home use) then it would just be your router and/or modem depending upon what type of connection your ISP provides.

Of course if you have a managed network service like Eros or something there could be more at play…

PC is connecting via wifi router.

I’m just running a basic Linksys router. If it’s not a problem on my PC then would it be a network caching problem?

I might have to wind up calling my ISP

It could be a caching issue I guess but there’s nothing conclusive to determine that.

I keep coming back to the fact that your trace route got through eventually so something is negatively impacting only your Apple devices via your home wifi connection and it sounds like you don’t have anything unusual in place that could interfere with the requests.

Just to double check, as I’ve mentioned it several times, but you never did answer it. Have you tried rebooting your router (and anything else between that and the wire that brings Internet into your home)? This is the first link in the chain to the site after your devices and the only one in your control to explicitly rule out.

Sorry that I was being evasive on this. I’d restarted the router and modem since this had started occurring, so I put it off until I wanted to sit down for a concerted time block troubleshooting this (I’ve been on with Apple support for two hours now). After restarting it today, the issue is still persisting.

One other point of data is that it’s not loading on a family member’s iPad (with no iCloud sync to my devices). So I’m beginning to think it’s a problem with the router and Apple devices specifically. I’m just feeling really clueless on this because there’s so many variables and I can’t pinpoint one.

Can you try connecting one of your Apple devices through ethernet to isolate the problem further, i.e. see whether the Apple devices have trouble connecting over wi-fi?

As it is, I don’t have an Ethernet adapter for any. If my tech support calls tonight aren’t fruitful, I’ll pick one up on Amazon.

Well my ISP confirmed that they weren’t having any issues or that it could possibly be on their end.

I went through Apple support and – even though the only issues are on Apple devices of mine – there’s no settings that are weird.

I emailed John but I don’t expect to hear anything back, and I doubt he’s got anything particularly weird in his site’s settings (though it doesn’t hurt to ask).

I called Linksys who wanted $29 to help me out. I’m not interested in giving them money for an old router, and if it’s a problem with the router I’m not going to reward them by cutting them a check.

I did a factory reset of the router and it didn’t help one bit. I think I have to give up unless I win the lottery and suddenly feel that it’s worth $29 just to be able to get DaringFireball on my Mac’s RSS, but I for some reason don’t feel that it’s worth the money to get a nicer router.

Thanks to everyone who offered any insight.

Out of interest is there any difference if you try to access using instead? I suspect not, but a quick one to try so nothing to lose, everything to gain.

And another quick try: Have you tried using other browsers than Safari?