Can't log into MacBook

This is a 2020 MacBook Air (last of the Intel ones). It was unplugged from power last night and had been working fine. This morning, it can’t be logged into and we get the attached. I’ve checked Apple ID on iCloud and that’s good. I’ve tried booting using CMD P+R then CMD R and we just end up back on this screen. We’ve tried resetting the Mac password but end up back here. It’s on 10.15 Catalina. Any help much appreciated. Thanks

“error connecting to the Apple ID server” indicates some network issue or Apple system status issue. Since you can post to MPU, I assume your local network is not an issue. Have you tried logging into appleid.apple.com from an iPad or iPhone with the same AppleID?

Double-check your PRAM reset procedure:

Hi. Checked Apple system status and all green. Local network ok as running other Mac & iOS devices on it. I’ll double check PRAM and let you know.

Good. This sort of thing is annoying and unwelcome – I hope it gets resolved. A call to Apple Support might be warranted since valuable assets are at risk and amateur sleuths really don’t know the circumstances.

1 Like

Checked all those and they all ended up with the same result apart from D for the diagnostic tool which runs and comes up with this:

When we click get started, we get stuck on this screen:

That last screenshot you posted is odd, as it is opening a file (file://), but saying “Connecting…”.
Could be normal, but looks odd.

Do you have a USB-C/A/whatever to ethernet adapter so that you can attach a cable to your router/switch? Thinking that WiFi in the MacBook may have gone south.

1 Like

Not sure about that. If Apple community discussions are to be believed (not always the case), the code “ADP000” in the first image means the issues are software related, not hardware.

@Richallum Have you spoken with Apple Support?

1 Like

Maybe a reach here but have you connected the MBA via Ethernet to ensure you are getting a true Internet connection???

1 Like

Thanks for all your help so far. Not got a dongle for ethernet at that location. Will be speaking with Apple Support now to see what they say and will post results here.

2 Likes

Apple support got involved and said it needs to go to them to fix.

Sorry to hear that.

1 Like