Command + backspace in Word on Mac

Hi all,

I appreciate this is pretty basic, and not exactly a MPU questions, but you’re all so helpful, I thought I would ask anyway.

When typing away (in Word) the command and backspace combination only deletes the last word, and not the whole line. When using Notes, as per standard Mac behaviour, it deletes the whole line.

I want command + backspace to delete the whole line in Word too.

Can anyone assist with how I can tinker with the settings to achieve this?

Thanks very much

Perhaps shift-command-left_arrow followed by delete?

Ahhhhhh that is helpful. Thank you. It doesn’t completely solve the issue, but does provide a workaround.

I think I have somehow changed my settings in Word, as command and backspace should delete the whole line. It works that way out of Word. I’m not sure if I’ve changed the settings or it is particular to word.

Nope. This behavior is the default for Word (just one small way they don’t support standard macOS conventions). Playing around in Keyboard Maestro it appears that creating a macro that sends “shift-command-left_arrow followed by delete” (@quorm’s suggestion) produces a result that matches other, more macOS native text editors.

1 Like

Thank you!

Good to know I haven’t messed it up. I will do that now. Much easier that way, and, as ever, thank the Lord for Keyboard Maestro. I love it!

3 Likes