DEVONsave v3: A shortcut for capturing clean PDFs into DEVONthink from websites on iOS

Just sharing an update to my seemingly-popular DEVONsave workflow:

TL;DR: clipping the web to PDF via DEVONthink To Go isn’t possible, and creating PDFs from websites on iOS is universally terrible (key problem: all links break/disappear :open_mouth:). So, this shortcut combo lets you create nice-looking HTML (customizable via CSS if you’re comfortable) from (most) webpages, and then DEVONthink 3 converts those to nice PDFs on the desktop.

It’s worked well for me for the past year or two, albeit there are still some sites that seem to block downloads of content.


The third one looks for a shortcut that doesn’t exist, despite having installed all three.
The missing shortcut is called :inbox_tray: DEVONsave identify type

thanks but does not work for me either.

Thanks for the report—I had anticipated some weirdness with the dependencies, but wasn’t sure exactly what the weirdness would look like.

In each of DEVONsave v3 and DEVONsave by type, could you scroll to the first Run Shortcut action and grant it permission to run other shortcuts?

The shortcut works if you select the helper shortcut with the correct name: “Devonsave by type”
Seems this used to be called something else, and that was still in there?


Yes that fixed it for me. I thought it might but didn’t have time to check earlier .

1 Like

Thanks! Phew.

The re-set shouldn’t be necessary, though… I wonder why it needs to be done. I’ll add an addenda to the article, in any case.

thanks, can you let us know when the corrected versions are posted? I want to recommend them to friends.

I like the shortcuts, just not sure they should all be visible in the share menu? (seeing that 2 are helper shortcuts?)

1 Like

@macsorcery Not sure I have enough info yet to be able to post a fix into the shortcuts themselves. Far as I can tell it should work from the get-go. I have added info about @JKoopmans fix if the error occurs in the post, though.

I also stupidly forgot to link to the instructions for getting the DT3 desktop conversion working. The post now clarifies this too.

(Link for convenience, though it’s the same as the one in the OP:

1 Like

This is correct. Once all three are installed (and in working order, apparently) you only need DEVONsave v3 in your share sheet.

hrm… not working for me. thanks tho. its why I prefer computers to ios devices.

If you provide more info I might be able to make it more robust.

Where/how does it break? Did you try re-selecting the right DEVONsave by type shortcut in DEVONsave v3’s Run Shortcut actions?

ok, it required a reboot of my iPhone but it does work but it never asks to convert to PDF… am I missing something?

I was going to say: I think that issue was a problem with Shortcuts itself, as I’ve encountered it too with various shortcuts and a reboot of the phone always allowed Shortcuts to run again.

And no. Apologies as it wasn’t clear from the initial version of the post, but DT3 on the desktop does the conversion work. Far as I can tell, it’s the only option. See the updated post for a link to the explanation of getting the desktop side working.

ok thanks, I will continue experimenting with it.

1 Like


I’ve checked the shortcuts and the DEVONsave v3 runs the shortcut DEVONsave identify type rather than DEVONsave by type. After I changed the subsequent shortcut to DEVONsave by type, it worked fine. Not sure if this how it’s supposed to be though.

Thanks! I’ve seen this report elsewhere, too. Sadly I have no idea why this happens, as it has never been called “identify”, and the version I export has the correct name.

Glad you got it working!

@ryanjamurphy this works well for text, though on a limited number of web pages. Most of the news sources I use block grabbing text content unfortunately. But the process doesn’t grab images. (So far.) The resulting HTML has the “missing image” icon in place of images in the body.

Thanks for the report. I have found the same, in general. This is another scenario in which Shortcuts actions are inconsistent. Try, for instance, a The Verge article (e.g., The images are fine! (Albeit small—note that folks who use images a lot might want to add in some custom styling to the shortcut to make them bigger.)

However, extract an article from e.g., the New York Times and it seems only the first image is grabbed.

I would love to make it more robust if anyone has any ideas.