Devonthink data loss anybody?

Thanks for highlighting that new post. It is possible that iCloud is the issue, rather than DT. Which is good, as I like DT functionality, but I might need to rethink how I sync.

That said, I set up a new, fresh database just a few days ago, indexing some folders. No system crashes or failures. I just did the DT verify after reading this: ‘Database XXXX is damaged.’ No clue how it has become damaged or how to fix it. It seems to be working OK.

1 Like

I don’t use iCloud (but for the native Apple apps, of course) for synching. Probably anecdotal and coincidental … or maybe a reason, but I’ve detected no data loss ever in more than a decade of using DEVONthink.

That’s the same person reporting the issue that is discussed here. If one is experiencing data loss with any software, without question it is a serious issue. I don’t want to suggest that it isn’t happening today. But aside from a confirmed bug in an earlier release of DEVONthink To Go that caused data loss, this appears to be an isolated occurrence that no one else is experiencing today.

3 Likes

Thanks for the reassurance. I didn’t tie up the usernames.

1 Like

I’d love to see a definitive answer some day. My understanding is Devon will never be able to fully research Oogie’s case because she can’t share the data and they can’t generate a test case on their end.

There’s an analogous case on the Obsidian forums with a similarly unsatisfying ending, although they got a little further in the diagnosis process.

When I did service work, one of the things that annoyed me to no end was when I needed assistance and called in and I heard, “Hm. No one else is having this problem.”
So I always kept that in mind when talking to my customers. If it was a unique problem that I hadn’t seen before, that didn’t make it any less of a problem for my customer - no matter the origin.

9 Likes

I just got my first corrupted file on DEVONThink today.

A bookmark saved from my iPad to the Inbox, then saved to an iCloud indexed folder. When the desktop file synced, I got a corrupted database error. The bookmark file (a .webloc file) was zero bytes. Still, the item worked as expected because I believe DT also stores the proper URL in the metadata that is synced to the sync database itself.

I think there is a pattern here, though I cannot confirm: folders indexed in iCloud and DTTG usage seem to be involved. I have seen my share of strange issues on indexed folders on iCloud as the database metadata gets synced before iCloud has synced the items, or iCloud is “optimizing” the local hard disk usage, but they were easily solved by updating the indexed items. This is my first data loss that I cannot explain.

This is a tricky problem to solve as when this happens, the database becomes “corrupted” and one cannot effectively work with it on multiple devices (which is critical for my use case). So I prefered to remove the offending file, empty the trash, and then add the bookmark again.

Have you reported this to DEVON Technologies via their support forum or a support ticket? If not, it would be a good idea to do so.

Not really, first because it is currently not concerning me and second because I do not have much more information for them to help debug the cause (as said, it was easily solved and I need my databases to sync between 2 laptops and 2 iOS devices for everyday stuff, and a corrupt database stops my workflow so I need to take action fast).

But yes you’re right I should.

Except that I do not use iCloud at all so that is notthe case with my issue as posted here and on the DT forum.

Oh and I no longer use DTTG at all either so that is also not the cause of the problem.

Do you use DT syncing at all?
Like between Macs?

That’s the only reason I could figure DT would want to write to a file, and I think perhaps it errantly thinks files in the other location are zero length.

I do use sync between two masc via WebDav to my Synology NAS server.

Could that be the problem? While it starting to become obvious that this is more of a problem than I had hoped, your’s seems uniquely worse than others.

1 Like

Perhaps, but the files are not synced, the files live only in the main mac hard drive. It’s just the DT database itself that is synced to the other system via WebDAV. Other things I sync using WebDAV do not have any problems where I am only syncing a database (my own SQLite one) or actual files. So while it probably can’t be ruled out it’s highly indicitive of a problem with DT that only things that DT has touched or looked at get destroyed.

1 Like

Please clarify. I’m not clear on your setup …

Does a copy of DEVONthink database package (holding hundreds if not thousands of files) reside on each Mac’s hard drive (two copies), And in DEVONthink the sync is setup and run automatically? Could you provide please screen shot of the “Show Info” screen in the DEVONthink sync setup?

Or are you copying the database package to the WebDAV server and the onward to the other Mac device? If so, what software controls this sych/copying?

Also, I understand all the items in the DEVONthink database are indexed into the DEVONthink database and not stored in the database. Or do I have that wrong?

exactly what folder name, on each mac, holds the files that are indexed into DEVONthink?