Do you keep old macOS installers? You may need to re-download them

Of probable interest to @ismh and myself, which makes me suspect it will be to others as well:

If you have older installers for macOS/Mac OS X/OS X, you may need to re-download them in a week or so, because the certificates they were signed with will expire:

It is yet to be seen which Apple will or will not re-sign. Hopefully all the way back to Lion, but who’s to say?

In the past it has been possible to workaround this by futzing with the date (basically resetting it to a time in the past before the certificate expired) so hopefully that will still work, even if Apple does not re-sign all the old installers.

Don’t download these before October 24th…

The certificates are not updated yet, so don’t bother re-downloading them right now, but after the 24th, here you go…

Mojave (10.14.6)

Apple Support: How to upgrade to macOS Mojave

High Sierra (10.13.6)

Apple Support: How to upgrade to macOS High Sierra

Sierra (10.12.6)

Apple Support: How to upgrade to macOS Sierra

El Capitan (10.11.6)

Apple Support: How to upgrade to OS X El Capitan

The links below do not (currently) work…

Unfortunately, as of this writing (17 October 2019), these all say “This app is currently not available in your country or region.”

But I have included the links that should work or did work previously.

Yosemite (10.10)

Mavericks (10.9)

Mountain Lion (10.8)

Lion (10.7)

1 Like

I keep all of them (go back to Lion) and always will if “they” let me.

Even if it is just to run an OS in a Vm somtimes

So it seems I have to do it again…

It no longer seems possible to download 10.7, 10.8, 10.9, or 10.10 from the Mac App Store.

I wonder if this is a temporary situation or a permanent decision.

Could be either. I remember a few years ago Apple upgraded its certificated encryption, which broke tons of apps downloaded from the Mac App Store, requiring a restart and re-authenticate. Took Apple several days to come out with a letter to developers explaining what happened and how it would be resolved.

Apple says “earlier versions are not available for download.”

I used this link to get El Capitan, It contains links to Catalina, Mojave, High Sierra, Sierra, and El Capitan.

Well that is some bullpucky right there.

Glad I have the installers saved locally… presuming they still work. Guess I’ll have to set some time aside to find out.

They’re still selling the install DVD for Snow Leopard, so why would they make the digital downloads of later versions unavailable? I don’t get it.

Everyone wants to forget Lion.

I downloaded the new El Capitan DMG and neither Parallels nor VMWare can build a VM from the DMG.


Hopefully it’s just me but I think I’m doing the same thing I tried before.

Update: So the DMG mounts a PKG which you have to install which will create the “Install {OS X Version}.app” which is what Parallels and VMWare use. I was trying to use the DMG itself.

Update 2: The PKG won’t let you install the “Install {OS X Version}.app” on a Mac that can’t run the version of OS X contained within the PKG. So you have to extract it using a tool such as Suspicious Package

Update 3: And when you extract the app, it’s only ~10 MB, so it’s obviously not the full installer, even though downloading the installer is 6GB. Come on, Apple, what are you doing?

Update 4: Ok, I think I figured out how to make this work. I’ll write it up.

Update 5: oh FFS, Apple! After I went through the whole process and finally got VMware to recognize it, now it’s claiming some issue with the security certificate and won’t install.

Update 6: I’ve written up my experience trying to get this to work. You can find it here:

1 Like

And I thought I took the long route to install El Capitan. I used a Yosemite VM to download El Capitan as I couldn’t download with High Sierra. At least, the link I used for downloading didn’t permit it. The Mac App Store was telling me my OS was too recent. Once downloaded in Yosemite, I ran the PKG file to get the APP file. That file was around 6.2GB or so. The APP file was copied to the host OS (High Sierra) so that VMWare could use it as the basis for an El Capitan VM.

I will take a look at the tools you used to if that could have helped me. Given the blog post about it, I’m not sure they were helpful.

I tried installing Yosemite last night and had the same experience. I’m trusting that someone will come along and figure out what I’m doing wrong.

Someone from the VMware Fusion forums came up with a solution of how to make a new VM from these DMGs. You can find the solution at