Double drive use for iCloud problem

So I did some testing this evening: someFile.jpg is an image file that was synced to the computer via iCloud Drive:

Used space : 958,537,990,144

cd ~/Library/Mobile Documents/com~apple~CloudDocs/Temp

ls -l someFile.jpg
907708 2 May 2017 someFile.jpg

du -h someFile.jpg
1.7M someFile.jpg

cp someFile.jpg ~/tmp

Used space : 958,538,326,016

cd ~/tmp

ls -l someFile.jpg
907708 15 Aug 22:39 someFile.jpg

du -h someFile.jpg
888K someFile.jpg

mv someFile.jpg ~/Library/Mobile\ Documents/com~apple~CloudDocs/Temp/someFile2.jpg

Used space : 958,544,031,744

cd ~/Library/Mobile Documents/com~apple~CloudDocs/Temp

ls -l someFile*
907708 2 May 2017 someFile.jpg
907708 15 Aug 22:39 someFile2.jpg

du -h someFile*
1.7M someFile.jpg
888K someFile2.jpg


The file that was synced seems to exhibit this behaviour (disk used is about double file size). If it’s copied to another directory on the same filesystem, it behaves as exprected (disk used is about the same as file size). If moved back to the iCloud Drive directory tree (still the same filesystem on this computer though), the file retains its expected behaviour.

Also: Checking used space via Disk Utility before and after a full iCloud Drive sync indicates that the disk used is about double the expected amount (and double what it is on my other two computers).

This is very strange.

Are all Computer are using APFS?
Do you have TimeMachine enabled on all of them?

All are using APFS on SSD storage. TimeMachine is enabled on one of the others and I’ve temporarily disabled TimeMachine on the computer in question.

Very interesting!
Did you try listing snapshots?

Arrr, thar be none matey

1 Like

Did you ever solve this? I have exactly the same icloud issue wasting 300GB. It’s not block size differences or time machine.

I never solved it. I had to put it aside because I didn’t have time to work on it.

I was going to rebuild the machine over the Christmas break but a couple of days ago it decided to die (it crashes randomly but always with 10 minutes of booting, much less if I try to start up a virtual machine, probably bad RAM, possibly a bad GPU/VRAM). It’s still under AppleCare for a couple of months more, so I’ll get it “repaired” and rebuild it and hopefully the drive space issue will be gone.

(As an aside: This is the second time the computer has has similar crashing issues and I no longer trust it to be viable in the longer term. For reasons, I need a reliable Intel Mac for a few years more, so I find myself in the uncomfortable position of buying an Intel Mini to tide me through)

Also: Welcome to the forum! :slight_smile:

Ahh your hardware issues sound like a nightmare - good luck. And thanks for the welcome!

After a lot of trial and error troubleshooting I think the doubled iCloud disk usage is an issue with Monterey 12.6.1 and possible a few of its earlier point releases (12.2 was fine). It appears the only effective solution is downgrading to Big Sur or updating to Ventura.

I initially had the issue for new iCloud files after updating an old mac mini used as a headless server to Monterey 12.6.1 from a much earlier macOS version (Sierra - used for legacy software). But I also replicated the problem on a M1 MacBook Pro with a completely separate user and apple account.

Some observations that might help you or future readers.

  • Duplicating an affected iCloud file and deleting the duplicate file “fixed” the original file but not other existing or new files.
  • Rebooting in safe mode seemed to get stuck in a loop but after a subsequent normal reboot seemed to fix the issue for existing affected files but not any subsequent new ones.
  • The issue persisted across a clean reinstall of Monterey 12.6.1 and across different users, different iCloud accounts and also a fresh user (i.e. no migration) on a completely fresh install.
  • The issue occurred regardless of where the file was uploaded to iCloud from - macs running various versions of MacOS, multiple iPhones, a different apple account).
  • Another M1 MacBook Pro with a completely separate user and apple account was unaffected on Monterey 12.2 but the issue appeared (for new files only) when updated to Monterey 12.6.1, and subsequently was resolved by updating to Ventura 13.0.1.
  • Downgrading the mac mini to a clean install of Big Sur 11.7.1 also resolved the issue.
  • More generally the file count info in the “Get Info” window seems to be buggy, occasionally showing incorrect file counts that seem to resolve themselves after some elapsed time.

Hopefully the issue with Monterey will be fixed on a future point release but I don’t know how likely that is now that Ventura is out…

1 Like

To add a further note. It seems that even after the doubled disk usage issue is resolved, files transferred via iCloud are not always an exact match of their original files in terms of file size.

I don’t know if this is related but reading these posts it seems that some extended attributes in the files’ resource forks might be stripped out.

In my case - several 100GB of images - I am hoping that it is just icons or other non crucial information, but who knows…

That blog has a wealth of information on various iCloud issues (and more general mac issues), how to investigate them, and a bunch of tools to help.

As a lifelong mac user it’s a shame to see the “It just works” reputation wearing thin. Churchill’s quote on democracy comes to mind - " Democracy is the worst form of government, except for all the others.".

1 Like