Driving me nuts! Google Drive on iOS-Files App

I may be as dumb as dirt but Google Drive on iOS in the Files app is driving me crazy–pun intended. :slight_smile:

Under locations in the Files app I have selected Google Drive as one of the locations. The problem is that it keeps defaulting to my personal Google Drive account rather than my Google Enterprise account. I checked my Gmail, Google Calendar, etc., to make sure I was logged into them using my business account thinking that may be the problem. Doing so has no effect. I have also tried toggling Gdrive on/off under the edit option but nothing changes. I want/need to save and access business files from the Files App on my iPad but I cannot figure out how to resolve this. I even deleted and reinstalled the Files app.

Is there a way to get the Google Drive Location in the Files App to show my work drive and not my personal drive?

Well, I’m feeling a little “smarter.” :slight_smile: I almost never use Google Sheets—preferring to use Excel. On a lark I opened Sheets to see what account it was signed into—sure enough, my personal account. When I signed into my business account in Google Sheets, the iOS Files app changed the default Google Drive to my business account as well. Problem solved. :slight_smile: Perhaps this willl be of help to others.

1 Like