Error 9 verifying update

My iPad Pro is about 10 mos. old & started freezing on black screen a few days ago. Tonight it bricked altogether but I got it into recovery mode and have been trying to use both iTunes and iMazing to restore iOS 11.4.1 . Each time it gives me error 9 “unknown error” which appears related to the device not responding. Sometimes it gets all the way through the installation and fails in the verification.

Any suggestions or solutions ?

Sounds like it is not well. If it’s only 10 months old you are still within warranty. Contact Apple Support (live chat works well, or they will phone you back, so you don’t need to waste time in their queue). Alternatively, make an appointment at the Genius Bar of yous nearest Apple Store.

Yeah I’m on chat now – they don’t seem to have much to offer that I haven’t tried yet…

Have you tried dfu restore?

yeah that’s where it was failing

What did apple say? Bring it in for repair?

I brought it in to a local Apple Authorized repair shop and they had the same result. i.e. it’s not the cable or the usb port. They said only recourse is to replace.