Failure adding to Overcast queue


#1

I tap the hamburger-plus-sign button underneath a podcast episode, tap “add to queue,” and the episode does not appear in the queue. Anybody else seeing this problem? Why does it happen? It’s driving me crazy.


#2

Overcast is bug ridden. Carplay doesn’t work from main podcast playlist. Bug has been there since 2015 at least. I’ve notified Marco Arment multiple times. Never fixed. Switched to Castro. Works beautifully. I use Carplay all the time it’s where I listen to most podcasts. Not working reliably is a non starter. It’s actually kinda funny because Marco likes to complain especially about Apple and bugs and he can’t even fix the bugs in his own app.


#3

Just worked for me on my iPhone. Are you using cellular data, I wonder if it won’t add it unless it can download the file and if you only download on WiFi it would wait?


#4

Nope. Podcasts are downloaded.

As a workaround, I’ve created a playlist called LIst and add episodes there.

This is not a big deal. It’s just driving me nuts.

To @ptgn123’s point: Overall, I’m very satisfied with Overcast. And Marco makes it very clear he does not provide support. Which is an interesting business model, but it seems to work for him.


#5

Cellular due to I’m driving when I would try to use CarPlay to start a podcast from the main playlist in overcast. It’s never worked. I’ve moved on to Castro.


#6

Does Castro do speed boosting as effectively as Overcast? I may want to fool around with Castro a bit. OTOH, I have about 275 unheard episodes in Overcast so what do I do with those if I switch podcast apps?


#7

It does in my opinion just as good a job. Overcast has an export function. Castro is free now with subscription like overcast. You can try it with no money spent.


#8

Just checked, works for me without any issues.


#9

Try deleting the queue playlist (swipe on it right to left) and see if that helps.


#10

It does not. Thank you anyway, though.