Help with Disk Space not being reclaimed after throwing to trash

So, I just started doing some heavy duty video editing last week. I’m using Final Cut Pro along with other music editing tools. On Friday night, I supposedly Ran out of Disk Space. Both Finder and iStat Menu showed that I only had 75Gb of my 3 TB fusion drive available.

I even ran the df:

chris@Home-iMac / % df -H /
Filesystem     Size   Used  Avail Capacity iused       ifree %iused  Mounted on
/dev/disk2s5   3.1T    11G    75G    14%  488726 30482971194    0%   /

I then proceeded to delete TON’s of files. Old iMovie Libraries, Old Music Files, etc.

However, my diskspace Didn’t Change, BUT my istat menus now shows I had 1.2T available. df didn’t change, Finder didn’t change and even the Disk Utility didn’t change. I wasn’t able to do anything.

This morning I woke up and magically, iStat Menu is now showing I have 2.41T available, finder is reporting 1.23TB available and when I ran Df:

chris@Home-iMac / % df -H /
Filesystem     Size   Used  Avail Capacity iused       ifree %iused  Mounted on
/dev/disk2s5   3.1T    11G   1.2T     1%  488726 30482971194    0%   /

I’m very confused. I’m convinced that iStat Menus is completely wrong, but I’m really not sure how I can explain what just happened.

Any ideas?

You were probably observing disk space at various times in macOS’s process of creating then pruning Time Machine Snapshots. There are tools such as Daisy Disk and Carbon Copy Cloner that can be used to manually prune these snapshots, but instead of being intrusive, just let macOS take care of the pruning.

1 Like

Thank you! I don’t use Time Machine but do use Carbon Copy Cloner. Maybe you are right. I was really concerned, but I’m feeling a little better now.

1 Like

I just bought another $500 external SSD because of CCC’s snapshot taking up 1T of space. Of course I didn’t realize it beforehand. But now I have plenty of space :slightly_smiling_face:

More info:

Perhaps related or perhaps not… I suspect there is a bug when Time Machine is used with Catalina and/or with SoftRaid.

My Mac has an 8Tb main SSD of which about 2Tb is used. I bought a second 8Tb SSD from OWC (“Acceslsior 4M2”); the 4M2 comes pre-configured as four 2Tb SSD drives which act as one 8Tb drive with the help of the SoftRaid app.

It seemed to work fine when I made my first time machine backup - it took 2.5Tb for the TIme Machine backup of 2Tb, which is about right. My data itself grows negligibly - maybe 100Mb per day. Each day the Time Machine backup file stayed at about the same size but Finder shows 500 Gb more total disk used daily. After 10 days, I had 2.5 Tb of files but 8Tb of space used. Time machine could not delete any old backups; instead if reported not enough space left on the drive to continue with backups.

I erased the SSD and restarted the process - same problem.

OWC is looking into the problem.

In the interim I am using CCC for daily clones of the SSD.


Not sure if this helps but I recently migrated my periodic iPhone backup to an external SSD (using drag and drop whilst holding CMD) and the disk space didn’t free up on my MacBook. For some reason the process seems to put the data into the trash - emptying the bin solved my problem.

Long shot but might be happening to you too - try emptying your trash!

It appears you (@chrisbog) are running Catalina. If so, the command “df -H /” only shows you what is on the root filesystem - which does not include user data! User data is mounted at /System/Volumes/Data.


Trash is empty

Root filesystem has only 10Gb

OWC still looking into it…

I truly suspect there is a bug either in Time Machine on Catalina or on SoftRaid with Catalina. Or some issue with this specific SSD. Or an issue with larger SSDs in general on Catalina.

Sounds similar to an issue I had recently, story here: How to delete purgeable space on external SSD?

Interesting possibility - thanks. But my internal SSD shows negligible purgable space yet dramatically more space used than accounted for in the file diretory.