HomeKit thermostat temperature ranges

Hi all, Long time/first time…I searched the forum first for Ecobee and HomeKit but didn’t find anything related. If this has been asked and answered, my apologies and please point me towards it.

I am having some issues setting the proper temperature on my Ecobee with HomeKit. When I create an action, such as “I’m Away”, the maximum range that the slider on the screen will let me choose is is a Heat to 64 or a cool to 78. I know the thermostat itself will allow me to heat to 45 or cool to 92. I’d really like to heat to 62 or cool to 80. Does anyone know how to do override these slider settings?


Have you tried using the ecobee’s home and away settings, along with allowing it to detect when you’re home or away automatically (using the ecobee sensors)?
This works really well for me, and I only have it connected to HomeKit so I can tell Siri to turn the temp down when I’m on the way home earlier than usual.
Another thought is that you might want to avoid large temperature swings. Due to the thermal inertia of cooling or heating your dwelling a large amount, you can actually use more energy than maintaining a smaller temperature swing.
For instance, 76 and 72 might be more efficient than 82 and 72.