HomePod problems after recent iOS update?

homepod
#1

Dutifully updating everything to 12.2. I had 2 homepods as a stereo pair in my living room. One of them was on apparently permanent standby, no longer paired. I unplugged it and tried to set it up again, but once I tried to pair it, it threw up a “set up failed” error message.

I gave up and moved it to the bedroom where it set up after two tries.

Then HomeKit showed both homepods as not responding when they were both working. I closed and reopened the HomeKit app and it’s showing them now, but I’m afraid to touch anything else so I’m just quitting while I’m ahead.

Sad that I don’t have a stereo system anymore, but I guess now I can listen to music in my bedroom. Seems like this should be easier. Any HomePod gurus know what’s up?

0 Likes

#2

Mine act wonky sometimes. I have a pair in my living room that are a stereo pair, and a few others. Sometimes one of the stereo pair stops playing and I have to diddle around until they work again. Unplugging, sometimes unpairing and repairing.
The HomeKit app is kind of wonky too. Sometimes it shows devices as not responding, yet I can tell Siri/the HomePod to do something with that device and it works fine. Sometimes it’s the other way around, Siri can’t ‘get in touch’, but the app can.
It’s all a little flaky, and I don’t try to intervene unless something has been going on for a few days.

1 Like

#3

I just had to unplug and replug one of my pairs today. They were still paired, but they wouldn’t play in a group with any other speakers.

1 Like

#4

My HomePod worked flawlessly for 13 months. Then on March 3rd it reported something wrong with my Apple Music account. After a lot of searching in the Home app (Apple, you can do better!) I finally found where and how to reenter my password. Fixed! The same problem and solution occurred another four times. The last time was Friday, two days after I updated my iPhone, iPad and HomePod OS. This time I couldn’t even set a timer. Everything has been working fine since.

In every case above, the HomePod continued to work with my HomeKit lights. I suspect the problem is in the WiFi/ISP/Apple server connection and not in the HomePod itself but how to know? And why now?

1 Like

#5

My HomePods intermittently complain about not being able to play music everywhere. The other ~6 months between, everything is fine.

0 Likes

#6

I have no HomePod issues yet with 12.2.

I do have a connection failure story. A few months ago, one of a paired duo of HomePods dropped off the wi-fi network, complained about not being connected, but nothing I did – or afterwards, the fellow at the Genius bar – could get it to get back on any network. It was under Apple Care and the Genius gave me a replacement, which works fine.

Thank goodness for Apple Care.

0 Likes

#7

After I updated my iPhone it wouldn’t connect to my HomePod to stream podcasts.

Then I opened the Home app, saw there was a nw HomePod version, and updated the HomePod.

I still couldn’t stream. :roll_eyes:

Waited a day. Then everything went back to normal. :man_shrugging:

1 Like

#8

Bowline, you have a lot more patience than I! It’s interesting that it fixed itself. I lost my Apple Music connection again this morning and had to sign out and sign back in to the service.

0 Likes

#9

I had patience because I was putting out a few little fires elsewhere that arose (coincidentally?) after the last iPhone update. For some reason Spotlight on my XSmax stopped working inside Settings (but it worked fine outside the app). The Apple Store made me Reset Settings after which I had to do a lot of housework to get everything working properly again: I had to reenter all the CVV numbers into my Wallet, I needed to log back into iCloud so my Messages would again sync with my Mac, I needed to reenter my phone number into Messages/AppleID/iCloud, and I had to manually launch all the apps from which I wanted notifications. A massive PITA. So I was in no rush to revisit the HomePod immediately, and when I finally did everything was okay.

0 Likes

#10

Bowline: Wow, what a mess that was for you.

I don’t know what to make of my month of HomePod woes. As I said, I had to reenter my music password this morning. Since then I’ve used HomePod to set timers. Twice, Siri came back with ‘Sorry, there must be a problem. Try again.’ In each case the second try worked. Do all these woes actually stem from Siri slowness? I wonder. The only time I use Siri is with HomePod and Apple Music.

0 Likes

#11

Have you tried streaming something to the HomePod from an iOS or Mac app? If you can, then perhaps it’s an issue related to the HomePod’s connection to Apple Music. (And if you can’t it could be a HomePod Wi-Fi problem.)

0 Likes

#12

Bowline: WiFi was one of the first things I suspected. I did all the usual WiFi voodoo. No problem whatsoever streaming from devices to the HomePod. No problem issuing commands to WiFi lighting fixtures. Until today’s timer problems I assumed Apple Music was the sole culprit.

0 Likes

#13

Anybody here using a VPN?

Since the last flare up of Apple Music password woes, I looked for Settings features that might be affecting my internet connection. Sometime after November 12 I had enabled the VPN feature of Cloudfare’s 1.1.1.1 app. Could changes in the app (it gets frequent updates) or on the VPN server affect the authentication of my Apple Music ID/password?

FWIW, I haven’t had a problem since turning off VPN and removing Cloudflare’s app. Crossing fingers…

0 Likes