How to force WiFi login page?

I’ve noticed I have this issue if I have custom DNS settings. Removing them seems to solve the problem for me.

Is it possible to have custom dns settings on an iPhone or iPad?

Absolutely. I customize all my devices.

1 Like

You can also use the 1.1.1.1 app to set up secure DNS quickly and easily:

Go to

https://1.1.1.1

To get the app for iOS or Android.

The drawback of using the 1.1.1.1 app is that it works like a VPN so can’t operate when a VPN is active. I’d love to use the app for the encrypted DNS capability all of the time but can’t when on an untrusted network because I use Encrypt.me there.

Actually, I use EncryptMe and 1.1.1.1 together all the time, and it works fine.

Quoting https://1.1.1.1/faq/

Is the 1.1.1.1 app a VPN?

No. A VPN app typically proxies all of your network traffic. The 1.1.1.1 app only overrides and secures your mobile phone’s DNS traffic.

It does show up as a VPN on iOS when active, but I can confirm that it does not interfere with EncryptMe.

This tip is a lifesaver for me, thank you! :grin:

For the problem mentioned REALLY
Neverssl.com

Listen to:

https://www.macgeekgab.com/rss/mgg_mp3.xml

I stand corrected about coexistence with Encrypt.me but I can confirm the 1.1.1.1 app cannot run simultaneously with Cisco AnyConnect VPN which my company uses.

The VPN profile for 1.1.1.1 and AnyConnect are in the same section on the VPN Settings in iOS whereas Encrypt.me is under Personal VPN.

It looks like one Personal VPN and one of the other VPN profiles can be active at the same time but two from the same section cannot.

Curious. I wonder if there’s a technical difference or just a “policy” one.

In any case, good to know that there are different kinds of VPN, which is something I was not aware of.

I can confirm @JoePreiser’s findings related to 2 VPN’s from the same “area” cannot be active at the same time. 1.1.1.1 and Synology’s VPN are in the same block, and enabling Synology will disable 1.1.1.1

I used to have this problem all the time. I found that typing the IP Address of the gateway usually triggered the login screen.

However once updated to Mojave it has never reoccurred. Touch wood.

I work for a retail store that has guest WiFi which is necessary cause the cell service in the area is terrible. My iPhone 6s worked on the WiFi for ever, there was a pop up login screen when I originally connected and never had to see it again. However I just got an Xr and it says I’m connected but I’m really not. I’ve tried captive.apple and 1.1.1.1 and example.com and everything that I’ve seen in the threads but nothing works…pleeeeaasse help me out

Try forgetting the network in Settings > WiFi, and tapping the circled-‘i’ Info-button.

!

!

Surf to neverssl.com, that should force the login page

1 Like

I tried forgetting the network then turning off the WiFi and restarting my phone and then trying again and nothing. The WiFi logo shows on the top but it still says it can’t connect to the server

I tried that it just says that it can’t connect to server. I’ve tried it using the same WiFi on my old phone and it works fine

I’ve also tried captive.apple.com on a phone that’s already fully connected to the WiFi to try and find the url for the WiFi log on page and it just says “success” but no new url

The “Success” message is all I ever get when owing to captive.apple.com from a fully connected device.

you may try browsing to the IP address of the router, eg 172.20.0.1 or 192.168.1.1 which may cause the login page to appear as it should.

You can find out the Router IP by looking at the details of the connection.

If you have a 169.254… IP address and no router then the network has not assigned you an IP address and you will need to try renew lease, toggle aeroplane mode or restart the phone. If you still get 169.254… you will need to talk to the network provider, perhaps your device has been somehow blacklisted.