How to Stop Scripts Editor from Loading?

I can’t figure out why the scripts editor keeps showing up on my MBP menu bar. I don’t need it. I’ve checked preferences for Finder, DEVONthink and Drafts but those don’t seem to be the source-though I may be missing it. How can I keep this from loading?

Script Editor/Preferences on the bottom.

@Ellis Thank you! I was looking for the preference option without actually opening the window. Much appreciated!