How to Stop Selection being copied


I have hunted for a solution but cannot find one.

I use TextExpander and I use Alfred principally as a clipboard manager. I also use pop clip. I draft a lot of documents and often copy bits from elsewhere that I have drafted before rather than retype them. My job regularly needs me to use a standard template that someone else drafted to cover multiple situations that I than have to edit down to cover the situation I am dealing with. There is a lot of cut, copy and paste! Everyone (sadly) uses Word and that is the app I use the most but this problem is not exclusive to Word. It appears systemwide.

I am finding that if I copy text in document 1 (template), then select a block of text or a line or a word in document 2 (destination document) that I want it to replace, rather than pasting the text from document 1, it just puts back the selected part of document 2. When I check the clipboard, the part I have selected is top of the clipboard not the selected text I want to paste. I have not otherwise done anything to cause a copy - I have not done Cmd C or anything, or selected anything if pop clip pops up - just selected. I have used other apps like typinator, copied, paste, etc. The same happens.

I do such a lot that if I could stop the selection of text from automatically adding to the clipboard, that would end the frustration and save me a stack of time.

Any workable solution would be fabulous!


Have you tried to find out if your selection action somehow triggers the copy command via a keyboard shortcut? you could try shortcut detective to find out:

as a second option: have you looked at the alfred settings for " Automatically paste to frontmost app"?


I think you may be a genius! In the Alfred preferences there is on the Advanced tab a ‘Pasting’ section with a tick box for ‘Auto-paste on return’. The description underneath says “Automatically paste selected item to the currently active application”. I have unchecked this and tried several times. It seems to cured the problem!

Thank you very much for your help.

Happy to help fix the issue :slight_smile: