hpPostScriptPDE.plugin will damage your computer

I’ve been getting this dialog for a couple of days when I try to print an email to PDF so I can store it in Devonthink (something I do on a practically daily basis). A web search indicates that this would seem to be a malware infection, but I have Intego real time detection enabled, and the daily virus search finds nothing. Further web search indicates that this may be due to hp invalidating some driver files, which have since been revalidated.

I suspect that if I delete the plugin my printer will cease to work, or at least I will no longer be able to print to PDF. I have a pretty ancient HP Laserjet 3030, for which hp no longer supplies driver software.

Before I throw my hands up and buy a new printer, anyone have any ideas?

That probably is no malware infection. It very well might be related to this issue you already were pondering about:

More on that at:

Yes, I read that. Trouble is, my printer ain’t AirPrint compatible, so far as I am aware. It’s too ancient.

I had the same message with my old HP, as well. Reinstalling the drivers fixed it. HP driver software 5.1 from here.

Sorry, my post did not age well and I was in a hurry when answering 3 hours ago. :slight_smile:

To remedy the issue there are several steps

  1. Make sure that you have every update installed Apple provides you with (in order to receive the “revocation of the certificate’s revocation”). That resolved the issue for many users.

If this did not work or if there is no update:

  1. Try reinstalling the drivers (see @dsh1705’ post).

If that does not work either:

  1. Delete everything that is connected to the HP software following the instructions I linked to (discussions.apple.com) (not for the faint-hearted!) and then reinstall the correct drivers again:

The HP drivers are out of date and need to be updated to work. If the Mac OS update or HP driver update didn’t work, Here’s what worked:

Open Finder, on the top menu hit Go > Computer > Macintosh HD (Usually) > Library > Printers.

Save (If you need to, and Delete the HP folder from there, (You’ll notice when clicking “Show in Finder” when you get the errors, these are where the files are, in this case old, outdated drivers and files).

Once deleted, open System Preferences > Printers and Scanners.

Right click (or Control click) select “Reset Printing System”, (This will delete any existing Printers and Scanners).

Once done:

If USB Printer, dis connect/re connect, you may see the option to “Install” the new HP software.

Sorry again for not being so clear about it.

Probably the same issue as discussed here.

I reinstalled my ancient HP2020cp using the “Generic PostScript Printer” option and have not had an issue since.

Thanks for that link, reinstalling the drivers has fixed the problem.

1 Like

I’m pleased to say that your second option worked. Wasn’t looking forward to the third one!