I need urgent help with a bootable USB-Stick on Mac (12.4)

I run into a problem with a damage to my disk2 (Data-Part) of my Fusion-Drive.
I am not able to fix it, while the Disk is active, but I am also not able to deactivate it with DiskUtility.
While I haven’t been forced to do so for a while, I could remember that I solved a similar problem with booting from an USB-Stick, to have the internal Drive inactive, and run Disk Utility from the USB-Stick.
So I searched for a description how to do so, and found a couple of them, all telling pretty much the same.
My big problem, they all stated, that after preparing the Stick with Terminal (createinstallmedia), restarting with the Option-Key and selecting the Stick, they all talk about an new „Installation“ from this stick, instead of just booting, and running the OS from that stick without a new installation on my FusionDrive.

I would be very thankful, if someone could push me into the right direction with my problem!

Sorry to hear. I think once you boot from the installer media you can choose Disk Utility from the Utilities menu at the top. That’s just from memory though, so… take it with a grain of salt.

Have you tried booting from the macOS Recovery System? CMD+R at startup as It sounds like you have an Intel Mac.

I have devided the USB-Stick into two partitions, and be currently trying to install Monterey on the second partition.
Installation is running now for almost 90 Min. with the indication of „less than 1Minute“ now for about an hour, and no visible change for the progress bar, so everything normal…

I am going to bed now, sending a prayer to SJ that it would be possible, to run (not just install!) macOS from an USB-Stick, and hope for a completed install tomorrow morning.

A little update:
I wasn´t at all able to install a running OS on the USB-Stick.
The installation stopped in between several times, and I was not able to get it installed, whether from the Installer on the second partition of the Stick, nor the Recovery File of the Mac or the Internet-Installation.
I don’t know why…

But, while I was on the Internet-Recovery of the Mac, I managed to use the Disk Utility on the Fusion Drive, while it was deactivated.
So for the time being, the Drive seems to work again, and I am hopeful, that I could recover at least my data.
I am afraid, that there might be a physical damage to the drive, but I wasn’t able to find a way to read out the S.M.A.R.T Data yet.
Does anyone knows a way to do so?

I think the only SMART data you can access from built-in apps is what’s available in Disk Utility (status is either Verified or Failing).

If you want more detail, I think you need a third party application like DriveDx.

1 Like

From what I’ve heard about fusion drives* … figure out how to get your data off there (at least backing it up) and come up with a speedy replacement strategy. Once they start failing, it’s only a matter of time.

  • edit: and what I remember first-hand about spinning drives!

FIRST THINGS FIRST. Disable your Time Machine backup and disconnect any other backup systems. Get a copy of that fusion drive on a new external backup drive! Do not update or overwrite any existing backups as you may corrupt them with bad and missing data. And then replace that drive soonest, as @tf2 recommends!

1 Like

It is really some odd behaviour I can see here.
I was able to remove all failures from the Data-Side (HDD) of the Drive.
The SSD Side was the whole time, acc. Disk Utility, without any failure.
DriveDX (@margaretamartin :+1: :smiley:) shows the SSD as failed, acc. to their health data, but I would assume, that this is not a real value, but simply the counter build in the SSD asking for buying a new one.
On the other hand, the HDD part is shown in pretty perfect shape?!
Also the Power-On-Times seems to be odd. The SSD shows only about 8000h, while the HDD shows 35.000h.
While I expected to have at least an even value, if not the SSD with a higher number of hours.

Time Machine shows me, while running a new Backup, 10% progress, and 160MB copied so far. On a 3TB Drive…
I have downloaded CCC and backing up the Drive to an external HDD, and it is also really fast. In a little over 260h, I can expect to be finished.
At least, it managed now 35GB already, within the last 1,5h. So it seems to be working after all.

TimeMachine itself seems to have stoped working already some Days(Weeks/Months?) ago, with an errormessage, that the 8TB TimeMachine-Drive has not enough storage, so it seems TM has stopped deleting the older files at some point.

I hope I can still get one of those sets with the glue from iFixit, I need for the refining of my monitor on my 2017 5K.
Does anyone knows an other source for something like that?

And are there any recommendations for a replacement SSD (Min.4TB or higher?)

I’ve had Time Machine problems like this — inability to remove older files. I researched this once and found some reasons for it. It’s not as simple as just removing older files to make room; there’s a complex set of dependencies about which files can be removed because of the versioning Time Machine does. I don’t remember the details; I’ll just say that you’re not alone.

I don’t necessarily object to this behavior, but I do object to Time Machine’s weak error message reporting. I’ve had many clients who were completely unaware that Time Machine stopped backing up.

Are you going to replace the fusion drive with an SSD? That’s what I’d recommend. (That is, replace both the HDD and SSD with one SSD.) With all of the error messages you’ve seen, I wouldn’t want to trust either part of the fusion drive in the future. It definitely seems like this is possible:

I don’t know if you want to buy from OWC (not sure about shipping costs if you’re outside the US), but I’ve been happy with the replacements I’ve purchased from them. If nothing else, their detailed specifications may help you to find a suitable drive.

Thank you.
Yes, I am in the turn to replace the Fusion Drive right now.
As there is a kind of a risk (Display) by doing so, I decided to try an external drive first.
I have ordered now a

and a

Both with a nice Prime-Day discount.
If this will not work out, the SSD will get a second live in my NAS, and I go for the internal replacement.
As the SMART-Data of the HDD still looking good, I hope to find a way to separate the Fusion Drive, and use the HDD as an additional storage.

1 Like