ICloud Desktop and Documents Option won’t select

I bought a new M1 Mac mini and setup from scratch. Most things were fine except that I couldn’t turn on Desktop and Documents iCloud sync. At the time I tried talking to Apple via chat but nothing they suggested worked. A few days ago I found a suggestion that if I created a new Admin user and rebooted with that user I would be able to sync for that user and afterwards the original user sync would work. The first part of that advice worked but the second didn’t. Now I have two admin users, one of which can access Documents in iCloud, and the other of which can’t. I can fast switch between them. I’m using the same AppleID for both users. I can just go with using the new user for everything, but it’s an annoying problem & wastes gigabytes of disk space. If I just junked the whole machine and started again there’s no guarantee that the problem wouldn’t persist.

Why can’t you delete the old Admin user?

Have you updated to 11.2 yet, I read this earlier:

It reports one of the things fixed in 11.2 is:

  • iCloud Drive could turn off if the Desktop & Documents option was selected.

Not sure if that’s exactly the same issue but if they’ve done some work in that area it might be enough to resolve the issue you’re seeing. :crossed_fingers:

Yes I have, but iCloud Drive has never turned off on me. I just have a situation where one Admin user on the computer can sync Desktop and Documents, but the other one can’t. When I’m confident that the new user is just as functional as the old one I’ll delete the non functional one.

When I’m happy with the new one I will. I’ve had some issues with eMail, DEVONthink and Music so far.