iCloud Files syncing isn't

Ever since upgrading to Big Sur and/or iOS 14 (not sure which is the culprit; maybe both), iCloud syncing of Files has been terrible. I have a workflow where I drop a file into the Downloads folder of Files on my iPhone and Hazel looks for it on my Mac and processes it. But for months now, it isn’t working. The workaround is on the Mac, I have to open iCloud Drive, create a new folder anywhere (it doesn’t matter the name or anything), which causes the sync engine to awake from its slumber and bring in the new file. I can then delete the folder.

But I have to remember to kick the sync engine when I get back to my Mac, at which point I may as well be manually processing the file. Is there a fix? Something I can turn on and off? A cache to delete? Anything?

1 Like

Take a look at this: Cirrus & Bailiff – The Eclectic Light Company

One of these may help you.

1 Like

I’ve noticed lots of lethargy too. “I know it’s there, I can see it in my laptop!”

Will have a look at @neonate ’s suggestion. Thanks!

iCloud is often mysterious.

I turned off (i.e., unchecked) “Optimize Mac Storage” in iCloud settings in System Preferences when I realized that the reason files and folders were not syncing to the laptop was because that setting was keeping them from syncing. The description in Preferences is confusing, at least for me. Even though I have plenty of space on my MacBook SSD, iCloud must have decided I did not and so it stopped syncing.

Syncing resumed when I unchecked “Optimize Mac Storage”.

3 Likes

They should have bought Dropbox… That “it’s a feature, not a product” statement is flatly incorrect. It’s a platform!

It’s clearly a feature from the looks of iCloud, OneDrive and Google Drive: every OS maker has its own implementation of it.

Now, if that feature could work flawlessly for something so vital on our beloved OSes, mind you, that would be nice indeed.

If they’d done it properly in 2008 it would have been the platform powering the multi-device Apple lifestyle we’d all be living far earlier than we did.

I was going to reply that this couldn’t be the source of my troubles because I never turned on “Optimize Mac Storage” since I always wanted all my files on my Mac. However, I went to look at the preference and at some point it got checked! Maybe during the upgrade to Big Sur? If so, I will shake my fist at Apple for flipping that switch without asking.

2 Likes

I hope that works out for you. It took a very long time (somewhere near 24 hours) for the sync to finish, and in some cases I had “stuck folders” that did not sync their contents until I clicked the folder.

I have the feeling that the Palm Pilot that I bought in 1997 was more reliable than iCloud.

Franky, given Apple’s resources, I just don’t understand why iCloud isn’t as reliable and feature rich as Dropbox. :thinking:

3 Likes

THIS.
Especially for such an integral part of the OS. It boggles the mind. It should be absolutely flawless. And yet I hear everyone complaining about iCloud around me – especially non-power users who can’t figure what the hell is going wrong. It just gives off the impression that it’s flaky. If Apple wants to milk revenue, in the name of all that is holy, make it an awesome product, please.

That would be my guess. It happened to a few of my user’s Macs when I upgraded them to (I think) High Sierra.

Turns out that wasn’t the problem. I unchecked it and it’s still not syncing reliably. So I came up with a simple workaround using Keyboard Maestro. It’s a macro that will run every morning to create and then delete a folder to make it download files. I may make it so that it does it every few hours.

(Don’t mind the “when Finder is in front” bit. I created the macro in my Finder folder, but moved it out so it will run no matter what app is in front.)

2 Likes

Great workaround! It should definitely not be necessary though…