iMac 2017 refuses to reinstall macOS

I have followed the Apple instructions for wiping my main drive in Disk Utility, but now I can’t get the OS back on the 2017 iMac.

The default partition “Macintosh HD” is there, reporting close to 1TB free space available. In addition, there is a “Update” partition of the exact same size - which feels weird because I only have a single 1TB SSD in this thing, nothing connected to USB or Thunderbolt either.

For good measure, I have tried installing macOS SIerra on both partitions, none of them will accept it. It counts down nicely to the last second, then throws up a very unhelpful message saying

An error occurred while preparing the installation. Try running this application again."

Running it again is of course not fixing it. Attaching a screenshot from Disk Utility in case any of you can see an obvious reason for this error. A bit lost for next steps to try here…


1 Like

Have you tried erasing again; then, installing from the internet?

Thanks F.

I have not tried erasing it again but I am installing from the Internet.

Noticed that there was a “First Aid” option in Disk Utility that I have never needed to use before. It comes back with an error code 8 for some reason. Maybe a second erase might handle that.

I am told to “run First Aid from Recovery” but I am already in Recovery mode. Can it be referring to the Recovery partition?

I wonder if it has something to do with the 2017 iMacs being dropped from Sonoma? I don’t know if you have access to another Mac but you could try generating a USB Drive install of Sierra. Then try installing from that instead of the internet.

I do think I would erase the drive again in order to see if you get the same message.

I did find this on the net.


Right, so I did another Erase and chose the Mac OS Extended (Journalled) file system. Still won’t complete the installer correctly.

Now, I don’t really want Sierra on there, it just happened to suggest that as it was probably what the machine shipped with. I will continue my investigations tomorrow and take your advice on creating a USB-installer from my current Mac Studio. If I could just skip ahead to a more current version of macOS, that would be neat.

By the way, the progression of screen shots and description on the Apple Forum URL is reflecting my exact problem, so will read that carefully too.

Thanks for your assistance!

1 Like

I generally always use a USB installer because (at least in the past), if I installed via internet it installed the lates edition of the OS that my machine when I brought had. So, if my purchase machine came with Catalina, then from the internet it wanted to install Catalina regardless of the current OS. That may have changed today. Hopefully, you will find a solution.

1 Like

I have just been through the wringer today, trying to wipe and recommission a 2015 iMac.

Step 1 - I booted it to log out of iCloud, at which point Backblaze automatically inherited the backup away from the newer iMac that replaced it a few months ago. :angry:
Step 2 - I followed Apple’s instructions to wipe the drive, which it did with no trouble… but see step 4! :slight_smile:
Step 3 - I booted the system to network recovery, which would not let me type a wifi password. Four reboots later, it decided I could now type in the password. :rage:
Step 4 - It asked me which drive to install El Capitan on… from a list of… zero drives. Wha??? :no_mouth:
Step 5 - I launched Disk Utility to discover it had one 2TB HDD and one 128GB SSD. It had been a Fusion Drive. :unamused:
Step 6 - I followed Apple’s instructions to rebuild the Fusion Drive. :nerd_face:
Step 7 - I installed El Capitan. And some updates to that.
Step 8 - I know this can take Monterey, how the heck do I get that? Another Apple support document provided a link, which is the only way to find it in the MAS. :man_shrugging:
Step 9 - done.

I remember this process used to be easy.

1 Like

Got my USB installer sorted today, loaded it with Monterey, re-formatted the drive for APFS and chose the “Install” option.

Worked on first attempt!

Thanks all, and esp @F.Jones :slight_smile:

1 Like

Yes, really way too many steps, esp. considering that in the beginning, you actually do “Try again later”.

Keep that USB Drive as long as you have that machine. Great to hear of your success!

1 Like