iMessage not sending on Mac

I’m currently using a 15" MBP Touchbar 2017 model running 10.13.5 High Sierra. I have messages in the cloud turned on, and receive iMessage on my MBP, but am unable to send messages from my MBP. Each time I send, I get an error message. Here’s what I’ve tried so far:

  • Disconnect iCloud account from messages
  • Reconnect iCloud account from messages
  • Disable iMessage
  • Enable iMessage

I’ve also tried restarting my MBP and resetting the PRAM (not sure why, but what the heck, everyone can use a good PRAM reset every once in a while :wink: ) Any suggestions?!

Have you checked the “send from”. Address on your mac. Is it the same on other devices?

1 Like

Sometimes it helps to whack iCloud by logging out of it in System Preferences. Rebooting. Logging back in. This is not the last resort, but it can fix errors and mishandling. Before you log out, make sure all your settings are correct, and your accounts settings in Messages are correct. Be aware logging out of iCloud then back in again will cause a complete resync of iCloud Drive, contacts, etc.

1 Like

Thanks for the suggestions. I ended up nuking the OS and starting over which seemed to do the trick…

Brute force solution! :joy:

1 Like