Inbox Rules in macOS mail app constantly restore themselves

#1

Has anyone had any experience with the mail app on macOS and ‘Inbox Rules’ reloading old or previous settings and not being able permanently delete or change a rule?

Right now if I delete an inbox rule - it shows deleted - but if I quit the mail app - then re-open it - the inbox rules all re-appear as if I never deleted them?

:thinking:

0 Likes

#2

What macOS version are you on?

0 Likes

#3

Running 10.14.4 with Mail ActOn.

0 Likes

#4

Yes! Rule syncing has been a headache for me for years. Multiple times I’ve had to completely delete them and start over, which really sucks when you’ve cultivated an extensive filtering system.

Lately I’ve noticed that Mail Act-On rules sync perfectly for the Outbox and Act-On rule tabs. Those are going through Dropbox for me rather than iCloud. As a result, I’ve started to make my more complicated rules on the Act-On tab and then create a simple rule on the Inbox Rules tab that runs the Act-On rules. It’s still not syncing between Macs correctly, but it’s much easier to manage than reconstructing, for example, my Advertisements 01 - 12 (with 20 entries each).

0 Likes

#5

How did you get them to delete without just returning? I can’t delete mine without them always coming back.

0 Likes

#6

I’ve done it a few ways and I don’t recall which had the best success.

Delete them from one and give it some time to replicate out. It may take a few tries, but only use one device to delete them.

I also tried taking everything offline, bring a Mac back online and delete from there. Give it some time to replicate out (like overnight time, not two minutes). Then bring things back one at a time.

Something that didn’t work was just deleting the rules plist file. In that case it seems to recognize the Mac as a new device and downloads to it.

0 Likes

#7

Yeah - I tried deleted the plist which just comes back. I only am using one Mac too which is another weird part about it. I will keep trying - lol. I have one rule that was temporary and now cannot turn it off!

0 Likes

#8

I’ve had this very issue with MAO + iCloud and couldn’t quite pinpoint the source of the issue. I spent an exorbitant amount of time talking to Apple about it and got nowhere, unfortunately. What did help however, was clearing out the plists and the inbox rules file on my mbp + iMac (make sure to make a copy/backup beforehand) and then logging out of iCloud on ALL devices. Note, I use Dropbox for syncing so I cleared the rules from there. I uninstalled MAO. I then moved over the inbox rules back to the proper folder on the iMac and let that “sit” for a few minutes. I then updated the rules I needed to on mail.app on that computer. I reinstalled MAO. After a few minutes, I logged back to iCloud on the mbp and subsequently on all other devices. I haven’t had issues since (knock on wood). Logging out of iCloud was key, I think. I hope this helps!

1 Like

#9

Now that you mention it, I think logging out of iCloud on everything then deleting the plist worked best for me.

1 Like