iOS Apps on M1?

Has anyone tried running IOS apps yet on an M1 computer?

Any recommendations on any such apps not available natively for macOS which run well on the M1?

I use apollo for reddit and overcast.
Both are fine.


I… forgot this was a feature. Hah.

Thanks for the reminder. Maybe DiscourseHub is an option…


Only some games, like them on the bigger screen. :smiley:

I use DiscourseHub for iOS on my M1 Air. It works fairly well with just a few little quirks.


I’m using it and it’s nice.


I’ve used PDF Viewer and Lumafusion on an M1 machine. Both seem to work without any issue.

I have tried lots of them. Never ran into any problems.

Cool! I’m a staff member at Discourse and have worked on DiscourseHub and I am curious, what are the quirks?


Hi! Nothing serious, but little stuff like when composing a response, having the bottome of the response input space off the bottom of the screen. It’s really not serious and I’m so happy that I can use the iPad app here (though a native Mac app would be delightful as well :slight_smile: )


IMO/IME — this feature is a huge disappointment because all of the developers that I wanted to support it have opted out, even if they have no Mac app.

Apple made something cool, and most of the iOS developers I cared about seemed to go out of their way to make sure their apps didn’t work on M1 Macs. Very disappointed, and not in Apple.


I see both sides on this one. Yes, there are some devs that just want control and pull their apps for no good reason. But by the same token, Apple’s framework seems - at best - half-baked and bug-ridden.

Apollo, for example. To sign in to Reddit, you have to use a Safari integration. Shouldn’t be a big deal, but you can click, and click, and click until the cows come home and the Safari page won’t load.

Until you quit Safari. And then restart it. Then EVERY SINGLE REQUEST comes up in a new window, in rapid succession. DOZENS of them. It’s like they were all queued up somewhere in the system, and restarting Safari opened the floodgates.

But that’s non-obvious when you’re sitting there clicking the link to use your Reddit account in Apollo, so naturally people take to the Internet to complain that the app is complete garbage.

So if there are any glitches like that with an app, I could see a dev pulling it from the store. I don’t think that integration issue is Apollo’s fault, but the Apollo dev takes the heat. I’m happy the Apollo dev hasn’t pulled the app, but I would understand if they did.

Overcast is another example. On iOS, if I’m listening to a podcast, I click the button on my PowerBeats Pro and the podcast pauses. On the Mac, if I’m listening to a podcast, I click the button on my PowerBeats and the Music app fires up and starts playing my library. If I have the Apple Podcasts app open, the play/pause works there too. And in VLC. And QuickTime. And…well, you get the point.

But it’s like Overcast is invisible to the Mac. It will, quite literally, let my podcast keep playing in Overcast while it fires up the Music app. Or if I take a Facetime call on my Mac, the podcast keeps playing as the call is answered.

That really, really seems like like a half-baked system integration on Apple’s part. And I wouldn’t think it would take too many of those issues to have devs want to pull their apps.


That’s a good summary and is consistent with what I heard from an app developer who I contacted about letting their app be used on the Mac.

I think it’s best to look at this feature as a bonus that maybe, sometimes kinda works, but I hope that Apple puts some effort into making it work much better.

1 Like

I hope developers will put some effort into making Mac apps and not relying on this obvious crutch which is never going to be a great experience.

Looking at you eero… and Hue… and… I shouldn’t get started


I think the rollout was mishandled by Apple. No wonder there was a general “oh hells to the no!” by devs.
Hopefully there will be a push by Apple to fix the damage done.


And also just noting for the record that it’s not like I installed dozens of these apps and cherry-picked two outliers that had problems - those were the first two iDevice apps I’d downloaded for my M1 MBA. And each had a glitch. :slight_smile:

For stuff that’s important, yeah. It really ticks me off when I have to use a phone app to manage something. Tiny little screens for managing super-important stuff isn’t great for me.

I don’t actually think the initial rollout was mishandled. But I think that after it rolled out, there were some obvious “sharp corners”. And as with many previous software glitches, Apple hasn’t prioritized the effort to file down those sharp corners.

Of course devs not migrating to their platform because of the glitches could cause an internal calculus to de-prioritize development on “less-used” things, without noting that the reason they’re less-used is because Apple hasn’t prioritized development.

It’s a mess. :slight_smile:

1 Like

this feature started being killed almost immediately and with every “.” release of Big Sur less and less iOS apps were sideloadable on M1. I have a rant thread somewhere here where I rage against the devs and apple so I won’t rehash it here. Here are the “unofficial” iOS apps I currently have sideloaded and working on my M1 Air:

Prime Video
iDOS 2
GV Connect
Hurricane Tracker
Dark Sky

I have not tried to install any iOS apps recently as I replaced my M1 Air with a 2019 i9 Macbook Pro. All of the above apps are working on Monterrey though but I do not update them as I do not trust the devs now.

Do you find Prompt works better than the native Mac options? Or did you just do it to check it out?

I like both Prompt and iTerm2. I use iTerm2 for local stuff though.

Fwiw, I use the iPad app Fig to read these channels on my MacBook Pro. Works fine.