iOS share sheet weirdness

Hi guys!

It is quite often I find myself wanting to share something between apps on iOS, but when the Share Sheet appears, the app I want to send to is not listed as a possible target. (And yes, I am aware of the “More…” button where I can turn on/off certain apps.)

Case in point - I am in the camera app Halide with an image I want to edit. Halide has basically no editing cabapilities built in, so I wanted to copy this to Lightroom. You’d think Lightroom would be the perfect target for a photo, but it’s not listed.

What is listed is my shelf-app Yoink. So, I send it there, go into Yoink, open the share sheet from there, and now Lightroom is showing up. Why? I do find the use of the share sheets hit or miss, and what annoys me is that I can’t figure out the logic behind what app-icons are appearing in the list.

Anyone know what’s going on here?

Not answering your question, but the whole share sheet, round tripping of files needs some thought and revision by Apple. Perhaps starting with the ability to associate preferred apps with file types.


It’s also “keyhole surgery”.

The issue might be related to the type of image being sent?

I tried both JPG and RAW options, none worked. Lightroom supports both.