iPadOS 15 and Twitter - weird behaviour

Is anyone running the latest public beta of IPadOS 15 and the native Twitter app? Each time I click on the Twitter icon (or call the App from search) it takes two attempts to launch the app. The first time, the click is taken but the app does not launch. On the second tap it does.

I have the latest version of the Twitter app from the App store and have tried force closing the App and rebooting the iPad.

It’s just a little weird and, if I was paranoid, would wonder what was being launched on that first click ! Does anyone else have the same happening to them at all?

Edit: I have logged a feedback with Apple too.

1 Like

I usually use another client but just tried it and I get the same result. First launch quits, subsequent launches are fine.

2 Likes

Twitter app won’t launch for me at all on iOS 15 on my iPhone.

Twitterrific works fine.

Same here - but only with the latest update for the twitter app in the last day or so.
Prior to that it was ok.

Update: Interestingly I’ve just had a new T&C notice pop up and after clearing that it’s launching first time every time.

1 Like

It’s definitely a bit weird on the beta.

1 Like

I am experiencing the same behavior.