iPhone 8 Suppresses Text Message Notifications Unless Bluetooth Disabled on iPhone or Mac

Hi everybody. I just upgraded from a 2011 MBP to a 2015 MBP. The 2015 supports a newer Bluetooth spec if I recall right, which means Handoff and some other features are supported. I’m wondering if this may be related. I will note turning off Handoff has no effect on this problem.

The issue: no notification sounds and the display does not come on when a text message comes in. When I turn on the iPhone display, I do see the notification on the lock screen.

Either of these stop the issue:

  • Toggle off Bluetooth in the iPhone Settings app
  • Toggle off my Mac’s Bluetooth

If I turn on Bluetooth again for both devices, the issue returns.

Messages in iCloud is turned on for both the iPhone 8 and the 2015 MBP. The 2011 MBP is turned off.

Any ideas?

Edit: Confirmed this issue happens with iMessage as well as SMS.

If you are actively using a device with handoff then the notifications go to that one first, and then the other devices silently/later (I don’t remember the exact setup). I believe this is working as designed.

2 Likes

Good to know. I was confused because SMS messages were not coming through to Messages on Mac. I triple checked Text Message Forwarding on my iPhone and discovered that the wrong Mac was toggled on. SMS message are now coming through to Messages on Mac.

Edit: The reason I chose the wrong Mac under Text Message Forwarding is because my 2015 MBP is listed twice because I renamed the computer and reinstalled macOS a couple times as I was setting it up. Anybody have an easy way to get rid of the extraneous entry?

IMG_8659