Issues installing a second Apple ID on Late 2015 iMac

Hi, I am in need of help having exhausted the google search and found nothing. I have purchased a refurb 2015 iMac and have set myself as the admin account and am now setting it up for my assistant but I am unable to add her Apple ID to her (standard) user account. Having successfully signed in it all looks like it is happening as normal (even entering the 6 digits for 2FA) then the very last screen turns to this:

Has anyone seen this before and can point me in the right direction?

Many thanks for any help :smiley:

Have you tried logging into to see if it indicates any problem with the account?

Thank you. Yes, her account works fine and we can also log in to iCloud on Safari where all appears normal.

1 Like

Did the 2015 iMac show up in the devices list when you logged in to Are there any other devices connected to the account?

@Joannab I think this was for you.

What operating system are you running? I’ve seen authentication problems with Apple IDs on Mac that are running old operating systems.

The device itself is listed as available on the account but still nothing when we are on the actual device…

We are running 11.6 so all up to date.

At this point, I can’t tell if it’s an authentication issue or something wrong with the macOS installation. If the former, that’s a call to Apple tech support to talk to the Apple ID people.

If the latter, there are lots of drastic things to try, starting with the easy thing of reinstalling macOS. I doubt that will do it, however. I’d bet you have to remove the faulty account at least.

Let us know what happens!

So - we got to the bottom of it. It was all to do with either the Apple ID being created on an Android phone and/or then logging in on an iMac that had previously had 3 new Apple ID 's created on it.

I solved the problem by creating a new Apple ID on a newish iPad and then it worked like a dream.

Thank you for all your help and nudges in the right direction. We got there eventually :grinning_face_with_smiling_eyes:

Weird! But thanks for the update. I’ve never seen anything documented about anything remotely like this!