Keyboard issues with Ventura


I have a brand new Mac Studio using a Logi MX Keys keyboard and MX Master 3 mouse. I have a weird issue that I cannot identify as either hardware or software. When I use Excel (V16.68) or Numbers I cannot tab within the spreadsheet. If I use the tab key, instead of moving to the next cell to the right on the row, the focus moves outside the worksheet, starting with the sheet name and then advancing across the controls at the bottom, then the top, and finally through the ribbon, surrounding each control with a border as you advance through them. If I use Word or Pages I do not see any problem with the tab functionality.

I have also noted that when using my browser the search bar will randomly stop inserting spaces when I type and random portions of the page are surrounded by a border. I can continue to type text, just not spaces. In order to be able to uses spaces again I have to close the tab and reopen a new tab.

I have searched for Excel issues and keyboard issues using Ventura but have not turned up anything useful. The keyboard and mouse combination were used with my previous Intel Mac Mini without problem. Any suggestions will be appreciated.


Has something changed with this setting on Ventura? This is what it looks like on Monterey where I’m still hanging out until odd things stop being reported for Ventura. (System Preferences > Keyboard > Shortcuts)

My mind went straight to that, too.

It is still there in Ventura…

…but it seems weird why Excel and Numbers would not intercept it and do their own thing as Word does. I just tried Excel on my system (with Apple keyboard) and Tab does indeed go between cells.

It’s as if Excel is protecting the sheet somehow. I know there has been an issue on Windows for years where pressing Scroll Lock changes the behaviour of the arrow keys, and it seems like it would be something of that ilk. Except… Numbers doing it as well seems very odd.

Thank you for responding. Previously I checked the “Keyboard navigation” setting in Preferences and tried it both “on” and “off” with no change in behavior. I also checked the worksheet protection and it is not protected. As a further test, I dug out an old wired keyboard and connected it. The result is the same, I cannot tab between cells.

I went back to Word and now I have erratic behavior there as well. If I hit the Tab key in a document, more than once, I get a blue border around the ‘document’ and a pop out box that I included as a screenshot

This is the pop-out box
Screenshot 2022-12-26 at 5.18.00 PM

If I try shift+tab, nothing happens