Keyboard Maestro not working with Big Sur 11.0.1?

Hi, hope this is the right place for the topic - apologies if I set it wrong.

I have just updated my Macbook Pro (test machine) to Big Sur Beta 11.0.1 and I just realised that Keyboard Maestro stopped working for me? I have some Actions for doing stuff in Ulysses (also current beta for Big Sur), but they won’t fire anymore - neither with “typed string” as trigger, nor “shortcut” as trigger. I normally do some text replacement, but the typed text trigger does nothing at all and the shortcut simply gives a “beep” without any results?!
Of course I did the restarts and also deactivated and have also reactivated security permissions for Keyboard Maestro in security settings, without success. Haven’t found any related entry in the system.log either.

Has anybody else encountered issues with current stable release of Keyboard Maestro with Big Sur 11.0.1? Or does anybody have an idea what I could test?

Thank you in advance :pray:

I’ve been using Keyboard Maestro with the Big Sur betas for months and it has been just fine.

I’m not sure what to suggest but if I was trying to solve the problem for myself I would definitely be operating under the assumption that it is macOS’ security that has gone awry.

Quoting from

Accessibility access to control your computer is required to use many features including selecting menu items, manipulating windows, pressing buttons, typed string triggers and the window switcher.

You will need to enable Accessibility permissions for both Keyboard Maestro and Keyboard Maestro Engine.

On modern macOS, you enable Accessibility permissions by opening System Preferences, going to the Security & Privacy preferences, and in the Privacy pane select Accessibility and ensure that both Keyboard Maestro and Keyboard Maestro Engine are ticked.

:warning: Note that for Catalina continues the tradition started in Mojave of being difficult with the Accessibility permissions, and I have several reports of people having troubles enabling accessibility for Keyboard Maestro Engine. You should report this to Apple using the Feedback mechanism. Remove the Keyboard Maestro Engine entry from the accessibility permissions, then quit and relaunch the Keyboard Maestro Engine (in Keyboard Maestro, File ➤ Quit Engine, File ➤ Launch Engine) to re-add it, and then you should be able to enable it.

:warning: Note that for Mojave it is fairly common for the accessibility checkboxes to be on but Keyboard Maestro still not have permission. Generally toggling the accessibility permissions checkboxes off and on resolves the issue. Alternatively, deleting the entries and letting the system re-create them usually works if toggling is not sufficient.

If you continue to have problems with enabling Accessibility permissions, ensure you only have one copy of Keyboard Maestro on your Mac, that it is in the /Applications folder, that you moved it there using the Finder and restart and try again.

If you continue to have problems, you can use the tccutil reset Accessibility command to reset the Accessibility permissions.

If you continue to have problems, contact support .

There’s also a good forum for Keyboard Maestro at


Thank you so much @tjluoma for your quick suggestions - I did the checkbox trick before, which didn’t seem to have helped. But the terminal command did the trick for me here, so Keyboard Maestro seems to be working again as far as I can tell - awesome.

Much appreciated!