Lutron Caseta Leap Homebridge Issue

I have installed the Lutron Caseta Leap plugin in Homebridge to use a couple of Pico remotes to drive some automations. The remotes have been added to the Lutron app but not paired to any of my switches. My Lutron hub is listed as connected and the Picos show up in Homebridge just fine. However, the Picos are not being added to Home app. I have restarted the Homebridge UI multiple times and deleted and reinstalled the Lutron Caseta Leap plugin. Strongly suspect that the issue is something simple. Thoughts?

I am running public betas on my iPhone, MacBook Pro (M1 Pro), and iPad Pro, but have had no other Homekit issues (that I am aware of). So, admittedly this could be a beta issue. I am not running betas on either my ATVs or HP minis.

Solved my own problem. Turns out this is a beta issue. After a full day of troubleshooting, and several exchanges with the plugin developer, as a last resort I pulled up the Home app on my wife’s M1 MacBook Air and low and behold all the Picos were there. Programmed a quick automation with one and it worked great. So, told the developer Brandon that I am officially his beta tester.

1 Like