M1 MBP Trackpad Bricked

Title says it all. The trackpad on my M1 MBP won’t respond to any input, either clicks or just moving the cursor around. Bluetooth mouse still works.

Things I’ve tried:

  1. Shut down + restart
  2. Quit Karabiner-Elements
  3. Boot into startup options
  4. Update macOS to newest version

Nothing has worked so far - suspecting it might be a hardware problem. Any help is welcome.

Is there a potential conflict with your mouse? I ask because years ago, I thought my MacBook trackpad stopped working or was working intermittently but the problem was that my mouse was turned on, in my backpack, with the button pressed.

Nope - I’ve tried it with the mouse turned off, and I only have the one mouse. Besides, the trackpad won’t even physically* click, which isn’t something I could see a mouse messing with.

*I don’t think the trackpad on these Macbooks is a physical button, or at the very least, it’s haptic-enhanced, so it may be a software issue.

The only other thing I can think of before taking it to Apple is to try Apple’s hardware diagnostics: How to Use Apple Diagnostics to Test Your Mac - MacRumors

Interestingly enough, I shut down my MBP intending to test this out, but when I attempted to boot into startup options, I held down the power button for about 10 seconds, followed by what appeared to be a restart and the trackpad now magically works! Not sure what happened but glad it’s working now. Perhaps holding down the power button for an extended period of time during startup triggers some sort of forced restart?