M1 won't switch to screensaver or sleep

Any help with this one? I get the feeling that this will either be a one check box solves it all or a really obscure software thing that never gets solved.

I’m running a MBA M1 in clamshell, 11.5.2, and am using a Dell D6000 dock with DisplayLink to two externals. Things were working beautifully after I set it up a couple weeks ago.

Two days ago, the machine stopped hibernating when I’d go afk. I can hot corner put it to sleep but it will sometimes turn back to the unlock screen. I reset screensaver to go off in 2 mins; sleep to go off after 3. Restarted, etc. Ran everything in CleanMyMax X, restarted, etc. None of those things solved it.

I’ve chatted Apple, and we’ve reset NVRAM, and done SMC reset. Probably 20 regular shut downs and restarts. We started in safe mode, and screensaver and sleep seemed to work in safe mode when it wasn’t docked in clamshell. Restart in normal mode, back to the problem.

Checking Activity Monitor for ‘prevents sleep’ shows:
WindowServer
powerd
sharingd
Overcast
FruitJuice
com.apple.WebKit.Networking
com.apple.WebKit.WebContent
ScreenTimeWidgetExtension

I started checking Activity Monitor last night for ‘prevents sleep’ after doing some googling. Only powerd has been on continuously with sharingd and FruitJuice intermittently popping in. These other ones seem to up continuously today when I’m docked and have all my work windows rolling. Work things: Chrome, Safari, Finder, Word, Excel, Preview, Calendar. Problem began before I downloaded Overcast. Some other peripherals running: Freedom, TextExpander, 1Password, Snagit, Fantastical Helper. Music is usually up 24/7 but not right now.

Anyone have any ideas?

Could be a Bluetooth device waking it up.
My headphones sometimes wake my Mac.

Just a side note, you don’t need FruitJuice to ‘exercise’ your battery. It’s fine to monitor it, but no need to run it down periodically.

Thanks @JohnAtl
Bluetooth devices are Apple keyboard and mouse and AirPods. AirPods are greyed out and rarely used at the machine. I’ll disconnect them and see if that helps.

Is Apple Watch set to unlock Mac by any chance ? I’ve had mine fighting against the sleep button a few times.

1 Like

Watch is set to unlock. That doesn’t work with the clamshell/DisplayLink thing.

FruitJuice was the culprit. I deleted it, and it immediately worked as expected.

I suppose I’ll ‘miss’ the stats, but otherwise, I’m floored by how well this is working. I’ve not seen any lag. I’m not doing any video or big media editing. Just basic files, some Music, and maybe YouTube here and there.

Must have been some amphetamine in that fruit juice :slight_smile:

3 Likes