Mac dictation works in Drafts app, but not with native dictation

I’m using an M1 MacBook Air in clamshell mode with a “FIFine” USB microphone connected to my Anker hub, which is connected to my Twelve South StayGo hub, which connects to the Mac via USB-C.

Dictation worked fine for a couple of months, whether with Drafts’ “Dictate a New Draft” function or the Mac’s native dictation (tapping fn twice). But over the last few days, the native dictation sometimes doesn’t pick up anything from the microphone.

The Sound preferences panel is using “USB PnP Audio Device” as the input. Input volume is set at about 70%.

I’ve tried restarting the Mac, resetting the Anker hub and moving the microphone to another socket on the hub and directly to the Twelve South hub. At some point the native dictation started working and it stopped working in Drafts. This morning it’s working in both scenarios.

Of course, there are too many variables at play here to pinpoint the problem, but where should I be looking? How could Drafts be getting the mic signal, but not the system?