Mac Studio gets warm when asleep

Yep, I will update this thread if anything does happen thanks.

The Genius said this is only the second Studio he has seen, and the first one was because the person needed help transferring files from their old Mac.

He did take extensive notes on my what I have done to troubleshoot it. He said Apple works off of feedback so he encouraged me to use the Feedback app or the website (I have already done that). He figures if it is not supposed to be getting warm, then a future macOS update will take care of it.

One interesting thing of note, I told him the back right top gets the warmest, but said I hadn’t looked up what is there. He said “Let’s find out,” and brought up some pictures. He said it looks like something to do with the power supply. So this talk of different PS, maybe be something to that?

Edit: He really wanted to blame BackBlaze too, which I found odd. He saw I was running that, got really interested and opened it up and started asking me questions about it. I assured him it was doing this without BackBlaze installed.

I also encountered this problem, which is driving me crazy. I hope you can find a solution. Thank you.

Thanks for posting. According to Apple, there isn’t a problem. Be sure to submit feedback through the feedback app or the website, that’s what the Apple Genius told me to do.

I’ve been having this same problem with my M1 Max Studio, set up as a brand new machine - not a restore or migration of an existing system.

When the system is active (I’m using it), it cools itself just fine. But it builds up heat while asleep, to the point that the case is fairly warm. There have been a couple occasions where I’ve come back to it after it has been asleep and the case has been cool, but 9 times out of 10 it is warm far above ambient air temperature.

I installed TG Pro (after I noticed this issue - not before) and my highest CPU core temp right after waking from sleep is usually 53C or 54C, and usually a thunderbolt port will have the highest temp in the machine of 59C or 60C immediately after sleep.

I have two Studio Displays connected to the Mac Studio - not sure if the combo of Mac Studio + Studio Display is a culprit in this or not.

Time Machine is not enabled (I’m using Backblaze and Arq though). I do not have any Adobe software installed. I have Syncthing syncing data to my laptop. I use Cookie from the Mac App store. But that’s it in terms of persistently running stuff.

And I can quit ALL apps, put the machine to sleep, and it will still be hot when I come back to it. I can leave it sleeping all weekend and it’ll be hot when I come back to it Monday morning. It doesn’t eventually cool off. It stays hot ALL THE TIME while sleeping.

Nothing shows as preventing sleep in activity monitor.

I have not tested the power consumption while it’s “sleeping” - need to figure out which drawer my killawatt is at the bottom of.

I contacted Apple about this a few weeks ago, and they basically told me to quit all of my apps before I put the computer to sleep… which defeats much of the purpose of sleeping a computer. But as I mentioned even doing that doesn’t keep it from heating up during sleep. They didn’t have anything to offer beyond that.

This is likely not that big of a deal, but it’s super annoying. A computer shouldn’t run hot indefinitely while it sleeps.

Thanks for posting. Starting to think this is more common than I expected. I have a feeling we aren’t going to get an answer on this either. All we can do is live with it.

On the other hand, this could be working as intended. Apple Geniuses don’t seem to know one way or the other.

I have the same problem for Mac studio and called apple service but no solution yet. I am not sure if you are also attaching apple studio display on this Mac studio as me. I found that if I cut off the power of studio display when turn the Mac studio asleep, it still would became warmer but much better than I leave the display power on. It still produced thermal as some unknown processes ongoing underground and the fan stopped to dissipate it, but it was obviously much less thermal out as I cut off the display’s power. When I touched on the Mac top, I could feel warmer sometimes and less warm the other time that I could accept. I attached my display on one socket with one separated switch so it’s easy to turn it off every time I put the Mac to sleep. You can have a try but not sure it works for you. I think it’s the best solution for me for the time being until the apple engineering fix this bug in the future.

1 Like

I must say that all this isn’t really encouraging me to buy a Mac Studio at this point in time.

I generally wait at least a few months before purchasing very expensive v1.0 hardware. It prevents surprises like butterfly keyboards.

OTOH I occasionally roll the dice and grab a couple pair of AirPods Pro minutes after they become available. :grinning:

1 Like

It was in the back of my head not to buy a first generation computer. On the other hand, I am still not sure if it is a real problem or not, it definitely seems odd, but Apple techs don’t seem to know one way or the other.

@Robert_Shi interesting that it might be related to the display. I am using an LG Ultrafine and a Studio display. I tried unplugging the LG, but I don’t think I tried unplugging the Studio Display. I might have to try that.

It and the fan running are weird little problems, but the Mac Studio still seems pretty sweet to me. Wish I weren’t out-and-about quite so much so a desktop would make more sense than a laptop for me.

A lot of modern day electronic devices (not just Apple computers) suffer from the issue that they’re getting too complicated to make them function well in all situations. Unless the manufacturer throws an awful lot of money at it. Which will make the device too expensive.

Also, because of mass production there’s always a fault margin with the components.

It’s something I personally find very frustrating. Not just with computers, but also with audio equipment e.g. Which seems to come standard with bugs and h/w issues included nowadays.

1 Like

Besides this thermal issue, I really like the Mac Studio. It’s powerful, quiet*, and has the perfect mix of ports for my needs. This issue aside, it really is a great machine.

* it’s not silent, but it’s quieter than the Trashcan Mac Pro it replaced was

2 Likes

I disabled powernap and womp via pmset in Terminal:

sudo pmset -a powernap 0 womp 0

and that seems to have solved the problem for me. I just came back to the Mac Studio after it being asleep for several hours, and it is the expected ambient air temperature and not warm to the touch like it previously would be.

I plugged in my Kill-a-watt the other day, and noticed that the Mac Studio would often be using as much power during sleep as it was when fully awake. So it seemed to be doing A LOT of frequent powernap activity. Which, I guess if the fans aren’t running but it’s cycling on frequently to do powernap stuff then it makes sense why it would get hot. Not sure why it consumes a full 13-14 watts during powernap activity in sleep. Maybe that’s the bug.

Because I disabled powernap and womp together, I’m not sure if maybe one or the other was causing the issue, or the combo was the issue?

I probably should have done more targeted troubleshooting (turning one off - see how it behaves for a day, then the other off, etc.). But I can live without both of them so it was easy to just turn them both off.


FYI - My power settings (via “pmset -g” in Terminal) are now:

System-wide power settings:
Currently in use:
 standby              0
 Sleep On Power Button 1
 autorestart          0
 SleepServices        0
 powernap             0
 networkoversleep     0
 disksleep            10
 sleep                1 (sleep prevented by sharingd, bluetoothd, powerd)
 ttyskeepawake        1
 displaysleep         15
 tcpkeepalive         1
 lowpowermode         0
 womp                 0

What is womp?

Are your fans staying off in sleep then? It’s just sleeping and staying asleep?

Womp is basically “wake for network access” - the checkbox for that in Energy settings and the terminal flag in pmset control the same value.

Yes, my fans do not run during sleep, and the Mac Studio stays asleep (no more power nap and no more waking for network access).

The computer has not gotten hot during sleep since I disabled powernap and womp.

1 Like

Guess I better try this then, thank you so much for posting.

I have never needed or cared about powernap, it’s really annoying that Apple removed the option in System Preferences.

Is it possible, that the question whether the fans are running, or not, depends on the location and the environment?
Height above Sea Level, Moisture and Temperature could possible be a trigger for a system to let the fans run, or not?!

I suppose it could be, especially external temps, but I have never had a PC (Mac or Windows) that got warmer when it slept. That’s just odd behavior. Summer is supposed to be arriving this week, judging from the weather reports, and I plan to see if this has an impact before I mess with the Terminal.

People I have talked to outside of this forum have said their Studio’s don’t ever go to sleep due to Plex or other software they are running. I kind of think that installed software might be making a big difference from machine to machine, but I have no idea on any of this.

I have the same issue, my mac studio often gets warm when Mac studio is on sleep mode. So if you have any solution, just let me know, thanks so much. I

1 Like