Mac Studio gets warm when asleep

I close my powernap, I will let you know if it works

1 Like

I had the same problem with my Mac Studio M1 Max. I can confirm turning off powernap resolved the issue.

1 Like

You guys with warm Mac Studios may be interested in a useful new app to which Howard tips us off.

3 Likes

Out of curiosity, are there any Mac Studio users in this thread (or owners perusing this thread) who do not have this problem?

Yes. I do not have this problem.

M1 Max, 64 GB ram, 1TB.

Here are my settings, both powernap and womp are on:


System-wide power settings:
Currently in use:
 standby              0
 Sleep On Power Button 1
 autorestart          1
 powernap             1
 networkoversleep     0
 disksleep            0
 sleep                0 (sleep prevented by powerd, sharingd, Music)
 ttyskeepawake        1
 displaysleep         60
 tcpkeepalive         1
 lowpowermode         0
 womp                 1

I leave my machine on over night and it is cool to the touch in the morning.

So while powernap appears to be a necessary condition, it does not appear to be a sufficient one.

I do not have this problem. M1 Max w/ 64 GB, 4 TB SSD.
After 2 months of use, the Mac Studio has never been warm to the touch.

Recently I rendered a slideshow to a 22-minute 4k pro-res video then transcoded to a 524 MB .mp4 file using Handbrake. iStat Menus showed substantial use of multiple CPU cores, but the fan was barely audible and the case was not warm.

To be clear, mine is the same way. Temps barely move when it’s awake. This is purely a sleep thing.

I thought it room might be temp related, but with summer here my office is warmer and the fans are not kicking on in sleep. Guess I need to figure out this Powernap thing.

karlnyhus - thanks for the recommendation for the Sleep Aid app. I installed it, turned powernap and womp back on, and then let my computer go to sleep naturally.

Several hours later, the Mac Studio is warm again, and Sleep Aid reports 4 hours of “insomnia” (during 5 hours of sleep). Looks like the com.apple.mds.repeatingHealthCheck is the biggest culprit (being active for basically the entire period of “insomnia.” And then the Photos app was doing background jobs for 3 hours. Which seems excessive.

I’m gonna turn powernap and womp back off, and see what Sleep Aid reports. But I’m pretty sure it’ll be normal sleep given my previous experience without the heat issue when powernap and womp are off.

1 Like

mds is Spotlight evidently. So I’m going to try nuking/rebuilding my spotlight cache/index and see if that helps.

Maybe it’s running healthcheck nonstop because the Spotlight index got corrupted or something - which would be weird on a 3-month old mac with a fresh OS install. But who knows.

I wouldn’t think that we all have corrupted spotlight databases. It can’t be macOS either though, otherwise everyone would have this issue. I don’t know, I am at a loss for the whole thing. I should probably try that app though.

Also I have reformatted twice. The problem starts as soon as you install apps and start using the computer.

I bought Sleep Aid – it’s a cool little app even though I’m not looking for problems on my MacBook Air. I like anything that makes my Mac’s inner workings more visible. And the devs are looking to add more features and useful information to this brand new app, such as insights into battery life.

@Leeabe51, I look forward to seeing what it says about your machine.

1 Like

Mine is never warm or hot - however I have it set to never sleep.

Likewise, always cool. Always awake.

I was thinking about it and it’s kind of irrelevant what it is doing in sleep, or is preventing it from sleeping. If it’s generating heat, no matter what it is doing, the fans should be coming on. They aren’t though.

It doesn’t mean I am not going to try the app, I am just sick of dealing with this.

Interesting the amount of people who put it to never sleep. I asked a popular podcaster if his was getting warm, and he also has his set to not sleep so he can run Plex on it.

My Mac Studio never warms up when it sleeps overnight, but the fans also never turn off. I thought this was normal behavior (as there is no reliable information from Apple about this), but it is a concern for me because it’s pulling in a lot of dust and cat hair. I posted about that on these forums. So I started turning off the computer when not using it for long periods (usually overnight).

My office is heated to 65-68ºF in winter and cooled to 73-76ºF in summer. I also have the MacStudio sitting atop a 6-inch round cake pan to elevate it from the desk and hopefully reduce the amount of cat fur that’s sucked up.

However, I just checked Energy Saver, and “Prevent your Mac from automatically sleeping when the display is off” is checked. I have no idea why this box is checked. I did migrate my MacBook Pro settings to this Mac Studio, but I definitely allowed the laptop to sleep!

I’m going to uncheck the prevent sleep box and see what happens overnight. I’d prefer to leave the computer on overnight if it neither heats up too much nor runs the fans continuously.

1 Like

That’s by far one of the most confusing and mysterious settings in macOS i think. There is probably a use for this. But I haven’t found one yet.

1 Like
  • Server use cases.
  • Macs that are often used for Remote Access.

Disclaimer: I know that there are means to access a Mac that is sleeping at least as long you are within the same network, but… it still can be a pain. Sometimes you just want your Mac to be up and running no matter what.

1 Like

I stand corrected. I thought there was a setting to disable the Mac to go to sleep. Which used to be there, afaik. Now the slider is only there for display sleep. This looks like some frontend to (part of) the caffeinate functionality.

For a server I’d use something else than a Mac though. :wink:

The heating problem may have been solved?? I had disabled my Studio from entering sleep mode because it was getting hot. (You do this by checking the box “Prevent your mac from sleeping when monitors are off”). Yesterday, I decided to test Sleep mode again. The power consumption was ~135 watts when I was using it. That dropped to ~18 watts when it entered Sleep mode, which is probably normal behavior. That’s a big change from previously when it did not drop noticeably in Sleep mode. I left it over night in Sleep mode and, this morning, the case was not hot and power consumption, before waking it, was ~35 watts. Again, that’s a much better result than I had been experiencing previously and I don’t know how to account for the improvement except that it may have been the result of the latest Monterey update. I’m going to continue monitoring this, but if it stays like this, I’m going to consider the problem solved.

That’s good :slightly_smiling_face: if the overnight heating problem never returns, but if it does :smiling_face_with_tear:, I hope you look into what your system is actually doing all night to use all that power and generate all that heat.

Inquiring minds, and future Studio buyers, want to know. Thanks!