macOS Catalina: System Audio or Music App's AirPlay to AirPort Express No Longer Working (iOS AirPlay Works Fine)


I just noticed that setting my Mac’s audio output for all system audio to my AirPort Express is no longer working on macOS Catalina. Streaming audio via AirPlay (2) to said AirPort Express from an iOS device still works perfectly fine.

On my Mac I also tried streaming audio from the Music app directly to the AirPort Express and the AirPlay popup looks as follows without any audio being played back by the speakers connected to the AirPort Express:

However, I am not sure if this is related to the OS update at all.

What else could be causing this problem?

The AirPort Express unit is running the latest firmware 7.8.1.
I tried rebooting the Mac and the AirPort Express.
I tried disabling/re-enabling the AirPlay capabilities in the AirPort Express settings.
There are no other audio plugins (like software from Rogue Amoeba or Blackhole etc.) installed that could interfere.
Also creating a new local macOS user and trying to playback audio via the AirPort Express showed the same behavior:
It connects, but no audio is played back. :thinking:

I am honestly out of ideas.

Thanks a lot :+1:

According to this guide, your AirPort Express icon has a lock on it, which means you need to enter a password.

1 Like

Thanks for taking the time to reply. Really appreciate it :ok_hand:

However that seems not be the issue. AirPlay on my AirPort Express was always password protected. And despite the password streaming audio from iOS devices is (and always was) working flawlessly. :thinking:

Just to be sure, I removed the password lock via the AirPort Utility, removed all stored AirPlay-related entries from my keychain, ran sudo killall coreaudiod (just to be sure) and set my system audio output to the AirPort Express, but still nothing. :confused:

I actually went ahead and completely reset the AirPort Express to factory settings. After reconfiguring via my iPad AirPlay was again working fine from any iOS device, but no audio was played back from my Mac.

I just found out that you can easily downgrade the firmware of the AirPort Express by holding down ⌥ (option or alt) when hovering the cursor over the displayed version number and selecting the desired firmware from the dropdown menu.

Downgrading to 7.6.9 and therefore omitting AirPlay 2 did the trick!

1 Like