Mail Big Sur Issue

I have searched and do not see an answer to my issue. I have been able to restore my most frequent mailboxes in the toolbar, I can configure the font in the list view to be bigger. I CANNOT figure out how to make the system font bigger/darker. It’s very hard to read.

I hope this screen shot comes through.

It looks big and bright here, but NOT on my computer.

In fact, it’s an issue in all the sidebars. . .I’m sure there has to be a fix but would appreciate any advice.

There’s a setting for sidebar text size in System Preferences > General:


There is no more Junkmail folder that shows all the spam folders for the individual accounts.
I now I have to expand every account, find the spam folder and check its content.

My only option is to clutter the sidebar with 4 individual “favorites” :-/

Thank YOU! That made a huge difference for my poor tired eyes.

1 Like

Thats what I did but they will still show as individual Spam or Junk folders that need to be checked one by one.
Before you could see all the Spam / Junk folders just like the “All Inboxes”.

Happy to hear how I can get that functionality back.

Do as @vgrovpro says … click on the “+” to right of Favorites in Mail, then in “Mailbox to add:” pick what you wan top add. the “all” ones are at the top of the list.

One more annoyance. I have favorites in the toolbar and in MacOS11, they appear also in the sidebar. This seems redundant.

Menu: View: “Hide Mailbox List” do what you want to avoid annoyance?

Here is a screenshot of what the Junk Mailbox setup looked like until Big Sur.
I only have to select the “Junk” folder to see, select all and delete the Junk Mail.

In Big Sur, I need to select every Junkmailbox individually and go through the process of selecting and deleting unwanted emails.

In Mail Big Sur, you should be able to:

  • Hit the + sign next to Favourites (should be right at the top of your mailbox list
  • From the dropdown, select All Junk

You should be something like this

Screenshot 2020-11-19 at 17.56.05



Jeezzz Apple went to far cleaning up the UI by hiding the “+” sign to add favorites. Your really have to know where to hover with the cursor to make it appear.

Either way I enabled, restarted Mail but its not showing all the Junk that is sitting in all the individual Mail accounts. Will see what it looks like in a few hours when more junk has come in.

1 Like

I have the spam / junk mail folders back under the “All Junk” folder.
I needed to change the location to where the spam / junk mail is stored from on my Mac to the appropriate folders on the server. It used to be there but got changed in the process of upgrading :-/