MS Word won't work on Catalina/Big Sur on Intel Mac Mini (2018)

Sorry for the length of this. TLDR = Ms. Word crashes on opening on my (2018 Intel) Mini. MS help does not live up to the name. Bought new license and that didn’t help. Can’t understand what’s going on. Works fine on my 2016 MBP with the same OS. ¯_(ツ)_/¯

Full story.

  • the other MS Office Apps open and function with no problem.
  • MS help peeps were nice but not useful. I went up three layers of help. The process ended with “we’ll get back to you.” Which I now realize was preceded by a silent “we’ll never.”
  • I tried adding it to the Login items. No use.
  • My laptop is in the shop now and I need Word for my work. I can work around by creating dox in Nisus or Pages and then formatting with Word on the web, but that’s a slowdown.
  • I asked for help in another discussion group (won’t say which) and the resident genius told me I had bought a premium product from a big tech company and I should ask them for help.
  • at first I thought it was license confusion, since I had used (and deleted) my first license for Ms Office on other computers, but the new license did not solve the problem, so that’s not it.
    i don’t even know how to trouble shoot this at this point. Any ideas?

Excited as along-time MPU fan to be on this discussion group!


Did you try reinstalling Office?

You may have already tried both of these options, but thought I’d throw it out there just in case…

  1. Will it open in Safe Mode for Word? - I believe it is holding the Shift key and clicking on the Word icon.
  2. Will it run in If the Mac is booted into Safe Mode? I think it is holding down the Shift key while booting.

I have also seen corrupt preference files and the templates being corrupt. Hopefully, you can get it up and going again soon.

Try to delete the preferences.

Usually with Office it’s either preferences or font issues.


Yup. Several times. I deleted Word. No effect. I went into Word and deleted Grammerly (or whatever the app of that kind was). Then I got an error message that Word couldn’t find Visual Basic for Applications (not that this means much in Mac) and it froze the application.

Thanks! I think I made it worse by deleting the Grammerly (or whatever it was) file. I downloaded Word after this but it made no difference. Still got the block from VBA. Safe mode didn’t help. Maybe deleting the entire MS Office Suite and reinstalling it is the next step. IDK.

1 Like

Can’t find Group Containers. Probably not part of Big Sur.

Tried it. Still getting VBA can’t be found. I’m thinking about deleting the whole MS Office Suite and reinstalling it and seeing what happens.

The reinstall may be a good idea. It should clean things up from there. I remember trying the reinstall and it worked on one machine. On another, everything needed to be removed, the computer shut down, and a reinstall from there worked.

Did this. Getting the same VBA error message.

Have you tried creating another user account on the Mac and using Word from that account. This would expose or rule out an issue in the Mac OS user account.

Did it again. Same result.