New Apple Watch not unlocking macbook pro

So I had a series 2 and it would unlock my macbook pro all the time. Never had an issue.
Series 2 and Macbook Pro up to date (minus Mojave)

I got my series 4, paired it, followed all the directions. But now it won’t unlock my macbook pro (running High Sierrra).

I keep going through all the steps, and now I get this message.


Yes, I made sure to follow those directions as well…Anyone else have issues ? Do I need to upgrade to Mojave to continue the functionality?

I know that last year I had to upgrade to High Sierra in order for my Series 3 to unlock my iMac. I’m not sure if there’s a similar limitation with the Series 4 and Mojave.

Until today, I was running High Sierra with the latest watchOS on a Series 3 and was able to unlock with the watch so there should be no issue if not running Mojave.

I did have to disable/enable the setting to get it to reliably work after moving the watch to the new home but it’s been solid since; even after upgrading the laptop to Mojave.

Possible suggestions would be to check that Bluetooth and WiFi are enabled on both the watch and the laptop.

Thank you everyone for the advice. I didn’t upgrade to Mojave yet, I am still waiting to verify if Logos 7 (important for me) will work with Mojave. So, in an interesting twist, the watch just started randomly unlocking my macbook and working all over again. Weird. I went for almost a week with this issue until I posted in the forums and then today “it just works” LOL.

Did you select your new watch in the system preferences on your Mac? I had the same issue (Macbook Air/High Sierra) until I went to System Preferences>Security & Preferences, then tic’ed the check box by the new watch and all worked fine.

I have a Series 2 which worked perfectly pre-Mohave, but since the upgrade, it has been a bit flaky, working only sometimes.